Z motors not moving

Hello,
I’m experiencing some strange behavior after installing version 5.0.0 (BLTouch) that I didn’t with the stock firmware on my Duplicator i3 Plus V1 (monoprice maker select).

Description of behavior:

  • I flashed ADVi3++ from the prebuilt binary (5.1)
  • change bltouch offset to match the indiego mount (which I have)
  • complete the sensor debugging process, and get OK for all wires.
  • select ‘auto bed level’ and the X/Y homing completes as expected, but then the system remains motionless when Z axis homing would take place. After 10 seconds without any Z axis movement, the LCD displays a “Homing Error” message.

Things I’ve tried:

  • Going to ‘Move’, where I can move the X/Y axes as expected, but am unable to move the Z axis.
  • Inverting the white/black wires on the BLTouch
  • removed the JST-XH I originally installed on the ZProbe for the BLTouch connector, and replaced it with direct solders
  • Reflashing the mainboard firmware to the ADVi3++ non-BLT version, and reinstalling the Z-min switch to see if movement is restored (it isn’t)
  • removing the Z axis motors from the couplers to see if there is any movement in the motors at all when selecting “move” (there isn’t)

Other Clues:

  • With the couplers removed, the Z axis motors resist any manual movement when plugged in, but are less resistant when “disable movement” has been selected, indicating that there is a connection.
  • There is no visible damage or obviously blown resistors on the mainboard. The last print I made was two days ago, which was successful (before switching firmware from stock).
  • I also installed “flexible” couplers at the same time that I upgraded to the ADVi3++ firmware, but as there isn’t any movement of the motors with the couplers removed, I don’t think that is what is causing this.

Any help in debugging this would be greatly appreciated!

Here are some photos of my wiring and the error message

IMG_0586
IMG_0588
IMG_0589
IMG_0590

Not a good idea. Be careful, the pin #1 is 24V.

Are you sure Z1 and Z2 are not disconnected somewhere? Do you have the same problem with both Z axis motors?

good to know re: the JST. Sometimes my crimping isn’t great, so I wanted to make sure there wasn’t a loose wire there causing it.

I am following the complete length of cable from the Z1/Z2 to the main board, there are no disconnects.

The same problem is affecting both motors.

What would the symptoms be of a blown stepper driver? As I understand the motors would still likely seize back and forth, or exhibit some other form of non-expected movement if the stepper driver is bad. In my case, I have no movement what so ever.

I’m going to try now putting a multimeter into the Z1/Z2 cable ends, to see if there is any power there when stationary/moving.

Thanks for your quick response Sebastian!

quick update: I reinstalled Wanhao firmware and the Z axis problem persists, so this isn’t related to ADVi3++ or the BLTouch. I ordered a new mainboard and will see if that fixes it.

I had the same issue with one of my printers after installing 5.0. The others installed without issue.

The fix was to install a previous version of ADVI firmware using Marlin 1.9… I think I had to do it twice and reboot (was a bit frustrated and can’t quite remember). Here is what I do remember:

  1. Unplug the USB cable and turn off your printer’s power
  2. After about a minute, turn the printer back on and wait another 5-10 minutes. It takes a bit for the motherboard to figure out its broken.
  3. Install ADVI3++ 4.0.6 using Cura (Update via OctoPrint failed)
  4. Unplug the USB cable and turn off your printer’s power
  5. After about a minute turn the printer back on
  6. Repeat if necessary increasing the wait times until you get a successful upload.

Sorry @justnoah but what you are saying does not make sense. How flashing and re-flashing can solve a hardware problem (as described by @Sam_Koebrich)? Very probably, your printer has serious hardware issue (looks like temperature related so maybe a faulty MOSFET) and what you are describing is only a coincidence, not a solution.

Using a printer that has a serious hardware issue is dangerous. And to recommend to other people to continue using their faulty printer is… questionable.

No worries @andrivet. I read the complaint as a problem with the Z-axis after leveling. I experienced a similar issue after flashing and described what I did to fix it. My specific problem was the Z-axis would not move when adjusting for Z-height. Very odd issue, but it makes sense. Its like it was losing the Z-home position which locks out Z-movement until Z is homed.

Since my other printers flashed fine and worked perfectly, I figured the upload was interrupted or corrupted. Re-flashing with the same firmware did not fix it. So, I flashed back to a previous version then flashed 5.0 again. That printer now works fine.

I do want to end with a thank you for your work. You have provided for the evolution and proliferation of the i3+ well beyond its expected lifespan. Your work has helped protect our investment for sure. Cheers to you sir!

-N

1 Like

thanks for the input both of you. My new board is arriving Thursday, I’m hoping that solves this issue. As downgrading to official wanhao firmware didn’t fix the issue, I’m guessing it has to be hardware.

If the Z-axis isn’t working with the new board, I’ll revive this thread for some more head scratching.

I will say that I removed both of the heatsinks off of the suspected faulty drivers, and there isn’t any sign of damage.

got the new board installed, and it’s working great. Issue solved.

If others find this thread in the future, stepper drivers can be blown without obvious signs of damage.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.