Z axis crashing into bed


I recently installed the 4.0.3 build in an attempt to get my BLTouch Smart V3 to work. I have checked the connections and it seems the BLTouch works when i self test, probe up, down. It is a solid red when i start it up, however, i cannot level because the printer will no longer home the Z-axis correctly.

I can control the Z-motors by octoprint, as well as in the manual controls, however the Z-axis homing button will not work, and any homing attempt made by either the auto-bed leveling, home all axis, sensor z-height, homes the X-Y axis correctly then crashes the nozzle into the bed with a setting of -270mm in Z, I let it go once and it restarted advi3++ after crashing the nozzle for about 15 seconds.

Monoprice Maker Select Plus
LCD: 4.0.3
Mainboard 4.0.3
Build: 190711172420
DGUS: 4.2
Marlin: 1.1.9

Bltouch Smart V3

also something I noticed was the bltouch sensor in the top bar of the lcd screen is grey and not orange as i see in a lot of your screenshots. I haven’t been able to figure out what that means.

any help would be appreciated.

How to you plug the BLTouch to the motherboard?

Gray = means that the leveling compensation is not active during a print. If not printing, it is always gray.

Sorry it took me a bit to reply. I followed the guide and double checked my connections, they all follow the guide, I bought and soldered head pins which seem to hold in place well without crossing any connections. here’s a look at the main board. Thanks again for the quick response! image image

I was searching around the forums and I came across a post where someone had trouble with z-homing. I raised the nozzle up and tried homing Z but nothing happened. when I pressed home all (*) the printer homed the X-Y, deployed the BLtouch, and when manually pressed the bltouch and it snapped up, kept going and was about to crash into the bed again. I will re-check the wires for continuity tomorrow when I am off work, however I find it hard to believe that to be a problem unless these wires are real cheaply made…

I decided to go ahead since it’ll be until afternoon CST before I can get around to it. All wires check out and have connectivity through to the bltouch, but i’m still having the same issue. I have also tried to reflash through octopi, the firmware used was ADVi3pp-BLTouch3-Mainboard-4.0.3.hex. Still not resolved yet. Will continue looking into it tomorrow and will document what I’ve done in case this comes up for someone else. In case it comes up it is the latest version of octoprint connected via ethernet on a pi 3B+

It looks like the problem comes from the white wire. This is the z endstop when using a BLTouch. You’re other wires (on the EXT connector) look OK.

I checked the connections again and resoldered the white wire to be sure. It still seems to not be reading.

When homing, the XY axis are homed to the middle, then the bltouch deploys, then when I activate the bltouch it senses and stows, but the nozzle keeps coming down. I’ll see if i can attach a video soon.

This indicates that the orange wire is OK but does tells nothing about the white wire.

Which exact model of BLTouch do you have? A picture of it can help.

Hi andrivet,

here’s the pictures


it’s an Antclabs V3.0.

I’ve just checked each of the connections from the main board to the actual BLTouch just past the sensor. I can confirm that they all have connectivity, so it shouldn’t be the soldering, or connectors. The white wire is connected and has connectivity through to the BLtouch.

The images are hard to take without getting all out of focus but I can assue all the conections are solid now. I still cannot get PA3 to fire.




I seem to be having a similar problem with a Cocoon Create Touch (HE161192), Firmware 4.0.0 and a BLTouch 2.1. It happens intermittently, but seems to work again after letting the head crash into the bed and power cycling, which is less than ideal.

The latest version (4.0.4) should fix this kind of problem. Apparently, the root cause is some excessive vibration of some printers and it triggers the BLTouch prematurely. I have changed some parameters to circumvent these problems.


Problem (for me) still appears on 4.0.4. Typically only happens after a G29 fails at the 9th probe point.

I’m having the same problem on 4.0.6. Any updates?

Just wanted report in that i’m seeing the same z-crashing issue on my Maker select Plus. It worked perfectly for 6+months, then it was an intermittent issue, happened once every 5-10 prints, now it happens every time a z-home command is issued via the touch screen or gcode. All of my connections are fine and if a slip a 1mm thick piece under the sensor while it tries to home, it stops correctly, so the sensor is working. I tried going into the settings and increasing/decreasing the z-offset for my mount however that didn’t help at all.

For reference, this is the mount i’m using: https://www.thingiverse.com/thing:2847014

Edit, played around with it a bit more. I needed to adjust the thumb screws on the bed quite a bit to get it to start reading again, but that ended up solving it for me. It doesn’t LOOK level at all, but the prints are sticking just fine.

@djuniah What you described looks like a (multiple?) hardware problem(s).

1 Like

Hi, i am having this problem on the latest version, any fix available? My soldering is fine, probe is working, icon is also gray.

Please follow the rules of this community and do not hijack the topic of someone else:


And to be clear: there is no problem with the firmware. The issue is elsewhere.