Y Axis stuttering when printing - Aldi Balco Touch UK

Good afternoon,

I have an Aldi i3 clone (Balco Touch with V5.2C board) and recently I have had severe trouble with the Y axis. The bed seems to jitter when it moves during a print. This only appears to happen when the printer is printing. During travel or when moved manually using the controls it is smooth. This is producing surface defects as pictured.

I have attached a slow motion video of the hot bed moving during a print which shows a noticeable stop/start motion to the print bed. This is producing the vertical lines shown in the test cube below.

[video=youtube;TYSGepeNibI] https://www.youtube.com/watch?v=TYSGepeNibI [/video]

20201116_131032
20201116_131026

Heres what I have done so far to try and teoubleshoot:

-Replaced Y axis bearings with Drylin nylon ones.
-Squared the frame and installed a z brace.
-Tightened the Y axis belt.
-Replaced the Y axis stepper motor.
-Upped the VREF of the Y axis driver.
-Replaced Y axis idler pulley mount with a stronger design from Thingiverse.

None of this has helped and I’m at the end of my tether with the machine. I changed to ADVi3++ several weeks ago hoping it was a firmware issue.

Printer Details:
Aldi Balco Touch V5.2C with BLTouch

Does anyone have any ideas what could be wrong as I am completely lost!

Kind regards,
David

Maybe you have wrong acceleration parameters in the firmware (Settings / Motors / Acceleration)

Hi Andrivet,
These are my Acceleration and Jerk settings.16055422185084604791505178294941
16055422792081463346870635077330

Those are not the default values. In particular, Travel is very high.
The default values are here:

I set the parameters as per the default parameters and still have the same problem. When I lightly touch the bed during y axis movement, there is a noticeable stutter. It appears to only be there when printing. During bed leveling for example, the Y axis moves smoothly without such stutter.
Could it be the mainboard thats past its best?

So maybe it is a problem with your slicer. Have you looked at the generated gcode?

Here is the Gcode for the calibration cube I used. I’m completely clueless when it comes to code and programming so looking through the gcode would be a complete mystery to me.

cALIBRATION cUBE.gcode (742.7 KB)

I compare your gcode with one I slice also with Cura 4.8.0 and do not see anything obvious.

Hi All, I had the same problem with my Wanhao i3 Plus (not sure what main board I have)… when running 4.0.6
I tried various fixes, resetting everything to default - and checked the belts etc.
Could not get it to work.

I downgraded to 4.0.3 which I had been running previously, and my Y axis is now working correctly.

@JonD @TotallyFlyTying How do you print? Please provide information so I can help.

I have checked manually all the differences between 4.0.3 and 4.0.6 and there is one major: the size of the internal buffer used by Marlin to print. So maybe (just a guess) it creates problems with USB printing depending of the software used. So it is important for me to have information about the setup you are using.

I always print from an SDCARD installed in the printer. I’ve only used the USB when upgrading the firmware.

My workflow goes Fusion 360 -> Cura 4.2.1 with a custom profile for the Wanhao i3 Plus that I have tweaked over the last few years.
Copy GCODE file to SDCARD - > printer -> print !

I might be able to put together a small test print that works ok on 4.0.3 and fails on 4.0.6 … and put the gcode up here. I’ll try and do that over the coming weekend.

In the same way as @TotallyFlyTying the symptom is a vibration/jitter in the Y axis that can be easily felt to the touch when it is printing. Manually moving the Y Axis from the touchscreen panel doesn’t cause the same noise/vibration.

Would be great. If you can also put your profile so I can do the same tests.

This is your problem… i have tried many times to use these on y axis and they just shudder at low speeds… when i use good quality metal bearings the problem goes away.

20201213_234550

20201213_234612

With reference to my post on Nov 19th, I finally got time to get some prints done to see what is causing the same issue on my i3 plus.

I thought the issue was with 4.0.6, because I didn’t see it 4.0.3, but that was an error on my part. The issue is the same.

The following print was sliced in Cura 4.8.0 with the default Wanhao i3 Plus profile. The second print same, except I slowed the print speed down by 50% to see if that helped.

Both were printed with a brim - I had removed it on the first print before photo.

print1

This photo is of a print of a small box 15mm tall, 62mm long and 36mm wide
The print is good except for one corner and only some of the layers up to the height that matches the internal corner pieces you can see.

print2
The second print is same, but I had modified the height of the inside corner pieces and the problem with the outside wall in that front corner has persisted, but again only as high as the internal piece.

Edited - added view of the otherside of the second print - which shows it is good.
print2b

The Y-Axis does make some weird noises - and I changed the bearings for metal ones, which has improved the printing.

Some prints work better - so wondering if this is a Y-Axis motor problem or bearing problem…

Gcode is here: case2.gcode (1.5 MB) if someone would be able to run a test print on their printer, and see if it works ok, that would be great :slight_smile:

Thanks.

Hi @Bryan - I am wondering if this could be my problem - may I ask where you got your bearings from? I may try replacing them again.

Might the y-axis rods need changing too ?

Thanks
JonD

i find the standard cura profile for the i3 isnt too good… it look like in your pictures you have an issue with retraction distance and speeds… also maybe the outer walls looks like you can see the infill. some extra perimeters can help hide this.

The rods shoulf be fine, i got the bearings from Amazon… im not sure if sharing links is allowed here, but if you DM me i will give you thin link.

I will add that I also had issues with swapping the Y axis bearings for Drylin bearings when I first attempted it. I ended up being able to use the Drylin bearings by swapping the stock plastic bearing holders with aluminum pillow blocks. You also have to be sure all the bearings and rods are parallel or they will bind causing all kinds of issues.

The aluminum bearing blocks help a lot with that, and I was able to get my printer running smoother and quieter with the Drylin bearings once I installed them in aluminum pillow blocks on the bed carriage. You also need to be sure the rods are very clean and free of any oil, or that will gum up the Drylin bearings and cause them to bind as well. Once I got it sorted, I prefer the Drylin bearings since they run much quieter and lighter than the linear ball bearings.

1 Like