X-axis doesn't work properly

i have a maker select plus with bl touch 3.1 using ADVi3++ 4.0.6 all was working fine but now i’m having trouble with the the X axis. for some reason the X axis won’t home and when i try it moves about a cm. and then vibrates in place. it responds to the controls erratically moving back and forth. i’ve checked the wires and reseated the plugs what can i try next?

You can try to swap your X and Y motors to determine if the problem comes from the motor of the driver (i.e. motherboard).

replaced step motor and cable and still get the same result

So it probably the driver on the motherboard.

do you know where there is information and instructions for replacing the x-axis stepper motor driver on a
maker select plus. sorry but u-tube didn’t come thru for my inquiry

Do you have the required material (and skills) to do micro-soldering?

No I don’t think I can

So replacing the driver on the board is not an option. Some people have plugged an external driver. For example: https://community.advi3pp.com/t/use-external-stepper-driver-when-your-boards-driver-wont-work-monoprice-maker-select-iiip/

How about changing the main board or even upgrading if possible

Yes, you can replace the mainboard (with the same model) but it is not cheap.

There is no upgrade. So if you put another board, your are on your own.

The external driver you sent me uses the 9&10 pins of the external connector. What about my bl touch? Is there a way to connect that also?

You have to adapt

Board from Wanhao. $35. Ups express $25. Not so expensive

Usually, board is around $100, not $35. Where do you get yours?

Wanhao3Dprinter.com.