Use EXTERNAL stepper driver when your board's driver won't work - Monoprice Maker Select IIIP

Posting this in hopes that it may help someone else out there :slight_smile:

My 3D printer won’t extrude filament! It won’t load or unload either!

I checked continuity of the wires all the way to the end of the ribbon cable – all good. I swapped the extruder stepper motor with the x-axis motor – stepper motor worked. I edited firmware and swapped extruder pin setting to another axis – stepper motor worked too.

Conclusion: Motherboard’s extruder stepper driver is defective. But since it is soldered unto the mainboard, it cannot be replaced.

Solution: Modify firmware and redirect extruder commands to an external stepper driver board (as suggested by zcornelli on this post from ADVI3++ forums).

I believe this solution is not limited to just the extruder driver. You can use this if any of the other axis drivers are defective. You just need to know what to modify in the firmware to make the adjustments.

Overall Steps:

  1. Prepare stepper driver board beside EXT connector
  2. Wire EXT pins to driver
  3. Connect external stepper driver
  4. Update firmware

Complete details on this link (with pictures).

If you agree, I will create a topic under “Troubleshooting” with the content of your article and of course, I will state clearly you are the author.

Hi Andrivet,

Yes you are correct. I absolutely agree.

Thanks and have a nice day!


Dave, thanks for the write up! It worked perfectly to get my extruder working again after I fried it doing the BMG extruder upgrade. The only thing to add is that I had to change the pin outs on the new stepper motor cable to match the schematic in your write up.