Unable to flash LCD with 4.* firmware

I am trying to upgrade my Cocoon Create 3D Printer Touch from 3.0.0 to 4.0.6.

I can flash the printer firmware with Octoprint/avrdude to any version I like - the correct version is reported in the terminal.

Unfortunately, I cannot seem to flash the LCD with the v4 firmware, no matter which version I select and which Windows method of creating the disk (either using Etcher with the unextracted img.zip or formatting the disk and manually copying the files over from the other zip).

The blue screen is displayed for a few seconds as expected, but then displays a single frame of the logo animation before swapping to the version mismatch screen. And this happens also when I am upgrading the LCD screen before the printer.

I can always successfully flash v3.* firmware, so for example I can flash version 3.0.2 to both the LCD and printer without any issues.

Does anyone have any suggestions?

Can you give more information? What are you doing exactly? Which kind of microSD card are you using?

I am following the provided instructions for updating firmware exactly. That is to say, I:

  1. Have the latest version of Balena Etcher
  2. Download the correct ADVi3pp-LCD-x.x.x.img.zip file
  3. Use Etcher to write the image to the microSD card - it passes validation
  4. While the printer is OFF, insert the microSD card into the slot on the LCD board (I have the LCD enclosure from bosbessenbasje)
  5. Turn the printer on

I have also tried the alternative Windows method of creating the card by formatting from Command Prompt (running as administrator) using the correct parameters, and then copying the unzipped files from ADVi3pp-LCD-x.x.x.zip to the microSD card.

Both methods lead to the same result I mentioned earlier: The blue screen is displayed for a few seconds as expected, but then shows the Marlin logo before going to the version mismatch screen.

I am using a brand new EMTEC brand 8GB microSD card.

Some users have reported strange things under Windows due to their antiviruses. Sometimes, it corrupts the content of the microSD.

You mean the logo of version 3?

Have you also flashed the mainboard part with version 4.0.6?

Having a look at the screens of 3.0.2 vs 4.0.6 - the image l see is 000_boot from the 3.0.2 firmware.

I have tried flashing the LCD to 4.0.6 with both 3.0.2 and 4.0.6 on the printer. Both yield the same result - a blue screen for a few seconds, then 000_boot.

I don’t have any antivirus on my desktop PC to interfere with the process.

I guess I could try to use my Pi to write the image to the card.

Sorry, I do not understand. There are two parts to flash. Have you tried to also flash the mainboard part of 4.0.6?
UPDATE: I read again your first message and I assume you have already flashed the mainboard part.

Which version of Windows do you have? If it is version 10, yes you have an anti-virus (Microsoft Defender), but I doubt it is the problem.

Yes, good idea.

Some people have sometimes a similar problem with the stock firmware from Wanhao. Some get some result by first flashing this: http://www.wanhao3dprinter.com/xiazai/LCD_display_formating_firmware.rar
and then the LCD part. I have not experimented myself.

Okay. I did something but now I find myself in the same situation as this user:

I suspect that this is the first image of the new boot animation.

It’s the end of the day for me, so I’m going to go watch TV and check the physical connection with the ribbon cable tomorrow.

Well, I won’t be able to solve this issue any more as I have just succeeded in ripping the LCD ribbon cable connector off the board. I guess I’ll have to swap to firmware that doesn’t rely on the touch screen…

You can buy a new cable. They are cheap.

The cable is fine - it’s the connector on the LCD PCB that’s damaged. I could try and find a replacement connector and solder it to the board. I would appreciate any guidance as to exactly what the connector is.

connector 10 pins FFC 1.0 mm pitch