Touchscreen Flash not working

I have upgraded to the latest version and it is printing well from the USB but I am unable to use the screen for anything anymore.
I have flashed it (with the MicroSD supplied thanks for that), it seems to go through the normal steps…pictures open and close one after the other…eventualy it stops, I have left it sit over night to make sure.
I then power off the printer, remover the card and turn it on and I have 1 picture there, the last one displayed while flashingIMAG0153

Any thoughts?

Wanhao i3 Plus (aldi version)

I do not see well, but it looks like you have 4 images (partial) on the screen?

Check the cable and the connectors between the LCD and the motherboard. It is often the source of issues.

I have dismantled, checked and re-seated the cables and still have the same issue.
In troubleshooting I tried version 3 firmware, same issue…
I then tried the original Cocoon Create firmware, same issue…
It would appear that it is not specific to the new firmware but I have no idea what would be causing this, I have successfully flashed it in the past.