Touch on LCD Display not working

tl;dr : when setting up usb connection for first time, I noticed LCD display suddenly no longer recognized touch. I was able to flash the LCD calibration image and the panel detected touch then, but when I returned to main menu, touch no longer work. Please help!!

For those who need more info, here’s a more detailed explanation:

Everything was working fine until I tried to set up USB connection to print from my computer using Repetier Host. I ran into some problems and never was able to figure it out, but somewhere in the process, the touchscreen stopped responding to touch. I’m not sure if it has anything to do with Repetier Host but its just when I noticed.

I have tried several things. Disconnect and connect the ribbon cable from the LCD screen and the motherboard. Reflashed the most recent version of the firmware, and made sure both motherboard and LCD screen share the same version.

The calibration start up sequence of tapping on the top right of the screen does not work either. I have flashed the calibration image into a microSD card and was able to enter the calibration sequence that way, and touch did work then, so I know the screen is not completely broken. But as soon as I return to the main screen, touch is no longer working.

If someone has any idea of things I could try, please let me know. I am beginner and have tried everything that was suggested online. I would greatly appreciate some help. Thanks!

Which ones. What have you done precisely?

So I was never able to fully establish that USB connection. When Repetier Host said I connected to my printer, I couldn’t home any of axis or move any of the motors from my computer. I tried changing the baud rate but that didnt work either. I have the Monoprice Select Plus which from their website says it can’t be connected to a USB 3 port which is what I have. I wouldn’t think this would have any effect on the LCD display itself but idk…

It does not look related to ADVi3++ at all, so please do not post in this category for such question. Your problem looks like a hardware issue with you printer. Flashing the firmware, or anything like (calibration, …) is probably useless.

Is your computer a desktop computer or a laptop? I ask this question to know if your usb port was connected to main earth and maybe you have some ground issues.

I move the posts to the appropriate category.

Maybe your problem is related to this:
https://community.advi3pp.com/t/usb-connection-to-mac-causes-firmware-to-get-wedged-and-serial-connection-to-fail

I apologize if this post is not appropriate for this forum. I assumed that since the touch worked during calibration but not any other time, it had something to do with the firmware. The computer is my laptop.

Thanks for you help

The LCD screen is autonomous (with its own CPU). So it is able to do the calibration on its own, even if the mainboard is not working properly.

But in other (normal) situations, the LCD sends commands to the mainboard and the mainboard modify what is on the LCD panel. So if there is something wrong with the printer, the mainboard may not able to work correctly and send those commands to the LCD panel.

That’s why there is a difference in behavior.

Is it possible that you made a shortcut somewhere when doing modifications? It looks like your mainboard is damaged.

1 Like

That is very interesting. So the mainboard is most likely at fault. It’s strange because the only thing that changed in between the printer working or not, was setup with Repetier Host, and with my limited knowledge, that shouldn’t change anything on the printer itself and damage the mainboard at all. Do you have any troubleshooting tips that might help me identify the problem with the mainboard?

on the lcd mainboard there is a brown flex ribbon connecting the touch digitizer to the electronics. maybe this got loose? try to disconnect this and connect again.

This hard to say. But you mentioned issues with things that are unrelated (LCD panel, motors, …). What they have in common is the mainboard.

It could also be the interface board on the back of the printer. Maybe the big flat ribbon cable has moved.

As the problem is probably at the hardware level, I would check all cables and all connections. I would also inspect the mainboard and the interface board to see if there is any obvious damages (burn marks, …)

The motor problem is related to my issue setting up usb connection, so I believe it is a separate problem than the LCD Display.

But thanks again for the advice, I will open up my printer right now and double check again for cable connections and any possible damage to the main board. I will reply again if I find anything.

just tried this but it didnt fix the issue. thanks for the tip regardless

I am a little bit confused. Can you explain what is working, what is not working? How do you currently connect (still through USB)?

So I inspected the mainboard and couldn’t find any signs of damage. I couldn’t find the interface board though. I used the pictures you had in another page as reference (http://sebastien.andrivet.com/en/posts/wanhao-duplicator-i3-plus-3d-printers/) but did not see any other board connected to the mainboard. One interesting find is the the lcd on the mainboard flashes differently when I power on through wall power vs usb. On wall power, the red led blinks 3 times and stops, but on USB it blinks twice rapidly 3 seperate times, then the normal 3 times. Do you happen to have a data sheet for the motherboard so I can try to figure out if these blinks mean anything? I couldn’t find anything online and that page I linked seemed to be very detailed. Thanks!!

Sorry for the confusion. I am a beginner and I might have used some wrong terms. The printer worked fine while being plugged into wall power, but suddenly the LCD stopped responding to touch. The motor issue I mentioned is not being able to manually control the motor through my computer. I believe I know the cause of this issue, so the main issue I am trying to fix is the LCD Display

The board looks like this:
image

You have it. It is behind the head of the printer, under a cover. It is connected to the printer with a big black ribbon cable.

I am again confused. You CAN’T power the printer with the usb cable. The usb cable can provide enough power for the lcd panel, but not for the motors or the heaters.

Found it. I thought it was located under the printer next to the mainboard. And I dont see any signs of damage either. Is there a possibility that it could be the ribbon cable that connects the LCD to the mainboard? Mine is slightly bent but the display still lights up and everything

Yea let me rephrase that. I have problems when I try to manually control the motors while the printer is powered through wall power but connected to my computer through USB. I send a command through Repetier Host to move a motor but nothing happens. But I believe its because my printer cant be connected to a USB 3.0 port, which is what Monoprice said in their website

I just spotted a typo. I meant to say the LED*** on the mainboard flashed differently when I had the computer just powered through wall power vs wallpower + usb connection. Not sure if this is significant at all