Thermal run away issues

New user to the firmware as I was trying to upgrade my Monoprice Select plus printer. I wanted to add mesh bed leveling, so I got a BLT Touch sensor, configured it and everything was working correctly. Until I had endless extrusion issues (unrelated to my current problem).

Eventually after a really bad print, I decided to replace the extruder and everything. Got a Bondtech with the i3 kit, and put it all back together after cleaning all the parts.

This happened to coincide right when we in Northern Washington state, had record low temperatures. Single digits for a week+. So whenever I tried to print I was getting Thermal errors. I had assumed it was because it’s too cold out (despite the fact that the printer is in an enclosure). So when the temperatures outside warmed up, I tried again, same deal. Couldn’t get above 230° C before erroring out.

I read through the posts here and it seemed like a thermistor issue. I replaced it with the same Golf Coast Robotics thermistor (Golf Coast Thermistor) that I had before.

I fired it back and thought this fixed the issue, it got past my ~230° C block, but then about 2% into the print it failed. Again with the thermal run away issue. I checked the temperature gauge in the box, it’s hovering around 49-54° F. Printer is in a garage with a ambient temp of 45° F.

This issue never was a problem with the stock firmware. Hell it wasn’t an issue with ADVi3++ for the first 3-5 prints I had.

I’m on firmware v.5.0 so technically haven’t got up to the latest version, however, I’m not sure if that’s my issue.

What happened/what went wrong?

Since I just replaced the thermistor, should I consider replacing the heater cartridge?

The image below was when trying to run PID tuning other wise it’s a thermal run away error.
image

Will probably change nothing to upgrade to the latest version.

Hard to tell what’s going on, but maybe the PSU is struggling because of the low temperature.

Thanks @andrivet even though you didn’t directly suggest it, your conjecture that the PSU was struggling led me to try moving the printer inside.

The printer behaved the exact same way, about 1-2% into the print it stopped. Even inside with an ambient temperature of 70° F.

This led me to try unplugging the cooling fan. Which…was the culprit. The Bond Tech After market mod, changes the height of some components. I suspect the cooling fan is angled wrong and is blowing onto the extruder nozzle or at the heat block level. Meaning once that fan kicks on temperatures start dropping and the firmware protections kick in.

I’m going to go with a printed rear cooling mount which will use other components of the printer to mount off of. Plus it will give me clearer visibility for prints/time lapses.

Thank you for your assistance :slight_smile: