The LCD panel behave strangely: When you press somewhere, it activates an element at a different place

You probably enter calibration mode by mistake or the LCD panel has forgotten its calibration parameters. There are different ways to solve this:

  1. Press the screen very rapidly 20 times.
  2. On a blank microSD card (8 GiB max), create a folder DWIN_SET. In this folder, create a CONFIG.TXT filewith the following content:
  1. Use the image I already prepared with the right CONFIG.TXT. Just write the image on a microSD card and insert the card into the LCD panel. The image is called and is available in Binaries.


  • I found method #1 difficult. Use method #3, it is the easiest.
  • Previously I said here to create CONFIG.TXT in the root of the microSD card. This is wrong. It has to be inside a DWIN_SET folder.
  • CONFIG.TXT has to contain TP_CORRECT and nothing else.
1 Like


I am having this exact issue and have followed your suggestions with no success. I rolled back my firmware to it’s original and found that touch was working fine. Putting ADVi3++ 4.03 back on caused the issue to occur again. When I press at the lower portion of the “print” icon, the about menu in the top right is activated.

I have tried reflashing, having the "CONFIG.TXT’ and pressing the screen rapidly, this had no effect. I also, as mentioned tried different firmwares, but no success with ADVI.

It is showing temperature etc… correctly.

Do you have any further suggestions that I might try?

My printer is an Aldi Cocoon Create Touch, running 4.03 firmware on printer and LCD.

What is the exact model of your LCD screen?

There are 3 markings I can see:
Screenprinted “DWIN” in the top left corner.
Screenprinted JP20987PA in the bottom.
A sticker with a barcode “DMT48270M043_05WT” and beneath that “171104” located in the center.

Is that helpful or is there other information I can provide?

This is the model number. It is the expected one. Are you using a support?

I’m not sure what you mean by a support? if you mean some sort of casing then:

I originally had it in the printer’s metal housing, but then when I was reflashing it, I put it in the 3d printed housing you suggest. Currently I don’t have it any any housing.

Yes. Check your cable between the LCD panel and the motherboard. It often moves a little and is responsible of weird problems.

I checked and rechecked the cable plugging in to the LCD… However I had failed to check the cable going in to the board, which was not in correctly.

After reinserting the cable, I reflashed as it still wasn’t working, I rolled back to default firmware, then back to 4.0.3. I then went through the previous process, tapping the screen ~20 times, the calibration menu came up!!! I calibrated, and now all functions appear to work.

Thank you very much for all of your time and helpful suggestions, I can’t believe I didn’t think to check the mainboard cable earlier. Live and learn!