Probe working intermitently

I know this is a common topic and I did my best to look at as many related posts as I could but nothing seems to have helped solve the problem. I’ve got a Maker Select Plus and a BLTouch V3 purchased from Amazon. As per directions, I did my best to make sure it is genuine. What I’m struggling with is the probe seems to eject intermittently. I can start a print and it won’t eject at all but if I pull it down once it seems to work fine after that. If I go to the settings on the touch screen and test the probe I’ve experienced the same issue but only once. To troubleshoot the problem I’ve quadrupled checked that I’ve got the wires connected correctly and I have now tried a new servo extension cable. I’m wondering if at this point others might think this is a defective BLTouch?

Can you give the link so I can check it is genuine. I do not support non-genuine BLTouch.

What do you mean by “eject” ?

Yes, it looks like a mechanical problem. This is common with non-genuine BLTouch. It happens sometimes with genuine ones but if you contact the manufacturer (if you have indeed bought the sensor from ANTCLABS), they will replace it at no cost usually.

  1. link to BLTouch: https://www.amazon.com/gp/product/B076PQG1FF/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
  2. When I say “eject” I’m referring to the probe moving down from within the body of the sensor. It just stays up inside the housing and doesn’t move down in preparation for contacting the bed. It just moves up a few mm and then tries again but doesn’t push the probe down so it thinks its at the bed already and moves up again.
  3. Hopefully the issue isn’t that its a cloan but if so I guess I can still return it and get the right one.

The link you sent is not the official ANTCLABS store on Amazon. In fact, this page has several vendors so I do not know from whom you bought this product.

So it is possible that you have a clone.

I’m usually pretty good about catching those things sorry for such a trivial mistake. I’ll return it and order one from ANTCLABS. Thanks for the impressively fast response time! Truly commendable

Personally, I always order from the official store of ANTCLABS on eBay (yes I ordered several, I have around 10, I always order 1 or 2 when they release a new one). I also know that some non-official stores are selling genuine… non-functioning sensors. Profit, profit…

ok, I’ll go that rout, better safe then sorry :slight_smile: Thanks again for your help

No need to be sorry. We all learn.

Just a quick follow up if anyone else looks at this. The issue I had was indeed a problem with the BLTouch. I’m still not sure if it was authentic or not but after replacing it I haven’t had any issues. The only thing I did was unplug the old sensor and plug the new one in. I reused the existing wiring so the only thing that changed was the sensor. Thanks again @andrivet for helping confirm what my issue was.

1 Like

Thank you for posting the followup.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.