Printer is skipping the actual print step

I’ve flashed the printer, and done a PID tune and extrusion test without issue. I’ve tried to do a test print and the following happens.

  • The printer heats up the extruder and bed
  • The printer says it’s starting the print, and moves the head to a start position.
  • The printer skips the actual “printing the object” step, but a green loading bar in the middle of the screen fills in a matter of seconds.
  • The print head moves back to home and the printer cools down.

I’ve tested with one of the files that was on the original Balco memory card, one from the included Cura 3.4 with Balco settings preinstalled, and one new gcode file from Cura 4.12.1. I’m at a loss how to debug this, as I can communicate with the printer via USB, it can read the files, it’s just not printing. I could try printing via USB but I’m not sure that would show me anything useful.

You can see in the video here that there’s no error message, it’s just not done any actual printing. The filament load and unload is fine. It’s not a failure to extrude, it just doesn’t start any of the actions needed to print.

EDIT: link removed, it is forbidden.

Which printer do you have exactly? Which binary do you have used? Do you have a BLTouch?

IMPORTANT: it is forbidden to post links to external videos.

Sorry re the video, I hadn’t noticed that rule. I posted it as when the printer was in warranty, Balco support always asked for a video, so I thought it would help.

Printer: Aldi Baldo 3D Touch.
Binary: ADVi3pp-Mainboard-51-BLTouch-5.0.2
LCD Binary: ADVi3pp-Mainboard-51-BLTouch-5.0.2

You get problems previously with this printer?

I looks like something is disconnected in your printer. Please check all cables, especially the ribbon cable that goes behind the printer. If it comes loose, it may behave exactly as you described.

No, I had an issue with my first printer, where the stop switch was badly soldered on. They replaced it with this one, which has been fine. I have just checked the cables. None are obviously loose, and prior to the flashing it was printing. This was a 2018 UK model with a touchscreen, so I tried the 5.2C firmware but still no luck. With a UK touchscreen model, should I use 5.1 or 5.2C?

I am generally unable to use the X/Y/Z controls in the firmware. And now it’s giving me a “Hardware error” message when I try and home it.

Based on your suggestion, I took the ribbon cable off and inspected it for damage. One of the wires in it looks to have got crushed, so I’m going to replace it. Any recommendations for good generic parts?

Thanks. I wouldn’t have thought to go along that cable, I couldn’t see how it may have got damaged. I reckon it slid under the base when I put the printer down.

1 Like

Availability will depend of your country so I can’t recommend a supplier.

I can’t tell. You have to look at the mainboard. The version number is written on it. It is generally a bad idea to use the wrong firmware. It may damage your printer.

Ok, thanks. I’ll get a torch and have a look on the mainboard. A new ribbon cable fixed the hardware error but it’s still skipping print, and it’s homing Z to the absolute maximum upper value, to the point the bearings come off the end of the rods.

If all else fails, I’ll just try to get the PID results off this then reflash it to stock. I really wanted to use your firmware for the PID auto tune.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.