PowerSpec i3+ Stops mid print

My PowerSpec i3+ began to stop printing , mid print.
image
The percentage complete count will rapidly run up to 100%. I also noticed that the print cooling fan also turns on at that time. Sometimes the operation is normal.
I have upgraded to ADVi3 firmware from the original, but it didn’t fix it. I have inspected all of the connections and everything looks good.
I have been printing carbon at 240 extruder and 70 on the bed with great results in the past.
Any assistance is appreciated.

You mean that your pinter with stock firmware had this behavior and then you upgraded the firmware to ADVi3++?

Correct.
I thought the original firmware became corrupted after checking all the connections.
I did replace the extruder thermistor in hopes it was faulty with a screw in type. But it did not help.

Can you describe more precisely what is happening? The print stops like if it was completed normally or the printer shows an error message? The fan is turned off when the print stops? Same question for the heaters (hotend and bed).

The print starts normally then it may simply stop. When it stops moving the ‘print complete’ percentage counter rapidly increases to 100% and the printer believes it is finished.
I have noticed when the printer stops early in the printing the print cooling fan turns on if it was previously off. I don’t known if this has any correlation or not.
On occasion the print will work to completion. But with 4 hour prints I don’t see when it fails.
The printer was operating perfectly prior to this unknown fault with the same print codes that it now fails on.
I don’t get any error codes.
Last night was my first full attempt with the ADVi3 firmware. Which seems I really like the graphics and interface.
Unfortunately the print also stopped unexpectedly.

How do you print? From a SD card? From USB, etc ?

I print from a sd card and have tried several in hopes it was a card issue but the results are the same. It seems that it will randomly stop.

I would start by doing PID tuning if you haven’t done one already, just to help rule out any thermistor issues.

The fact that this occurs with different firmwares really makes it sound like a problem with the SD card or the card reader on the board. If the cards are of the same brand and size, you may try using a card from a different vendor/source.

One common scam with SD cards is to modify a small capacity card to report itself as having a larger capacity. I don’t know this for a fact, but it wouldn’t surprise me if the behavior you described occurred when printing a file saved to such a counterfeit card as any data written beyond the actual capacity of the flash on the card would result in corruption or the file being truncated. As soon as the file got to a point where it wasn’t valid gcode or was truncated, the print would stop. If the card worked fine at first but started acting up after you wrote additional files to it, it’s likely you have a counterfeit. To check the SD cards you can use H2testw on a Windows machine or F3/F3X on linux/Mac. This page ( H2testw (Windows) - 3DS Hacks Guide ) has a decent write up and pointers to the utilities.

If the cards check out, another thing to try would be printing the same gcode via the USB port instead of from the SD card. I know you mentioned that you have printed that gcode file before, but if the behavior is the same when printing from the USB port, that makes it less likely that the SDcard or card reader is the problem, and more likely that the problem is with the gcode file or some other hardware component.

Another useful check would be to monitor the console output of the printer while it’s printing and see if anything unusual is reported. Octoprint would let you do that easily, if you can get it set up and connected to the printer. Not sure if Cura or other slicers have consoles that would let you monitor the prints and save the console output.

I hope some of the above is helpful.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.