Plus Mark 2 - Z axis hits bed on home and touches bed during levelling moves

I have a Wanhao i3 Plus Mark 2 (5.4 board) on 4.0.6 with an inductive sensor (blue tip with adjustment screw).

I’ve installed a glass bed (on the magnetic sheet) and the sensor is set to trigger at ~1.5 mm above the glass bed.
IMG_20201123_171812
When I home the Z axis the nozzle hits the bed - pushing it down ~ 1mm.

When I run automatic levelling the nozzle homes (crashing as above) and then during the levelling process the nozzle runs along the bed - potentially scratching it and damaging the nozzle.

This issue may be similar to Auto Bed Level function scratching glass bed.

The result of the levelling process is good for printing.

Additionally during levelling the coordinates of the 9 levelling positions are incorrectly shown on the screen (it reports x,x rather than x,y)

Video of levelling EDIT: Links to external videos are not permitted here.

I noticed the Z offset was zero (even though I had prevoisly set it) - so I changed to 1.6 mm - but it doesn’t seem to make any difference. The printer remebers the measured sensor z position IMG_20201123_172657

Can you give more information:

  • Does it work before you installed the glass bed?
  • Which firmware have you installed (full name of the file)?

The Firmware file is ADVi3pp-Mark2-Mainboard-4.0.6 installed on 3/10/20.

I installed the glass bed at the time I upgraded to ADVi3++ and I also changed from the orange to the blue sensor as the blue one works with/through the glass.

(The main reason I upgraded was the stock Mk2 firmware levelling was a problem, it used to contact the bed during the vertical probing stroke on the right side of the bed)

It is the right firmware.
It looks like you have to adjust the position of your sensor to take into account the height of your glass bed.

I can adjust the sensor height and/or the sensitivity and measure where it switches - which I can enter into the settings (setting / sensors) screen - surely it doesn’t matter where it is - as long as the switching point z distance is correct.

I initially thought that the setting (above) was automatically calculated and over-written by the firmware when I set the Z height (Controls / levelling / Z-Height) - but it appears not. The strange thing is the Z-height in settings was zero today - even though I set it in the past.

I will try adjusting the sensor height / sensitivity and report back.

I don’t think it is right. Use the z height screen instead.

Looks expected depending of what you have done.

I did some testing (with the original build surface - so as not to break my glass) and, as you suggested, I moved the sensor down (so, in effect, the nozzle was higher relative to the switch Z trigger height).

Now the homing motion and traverse during homing are higher (clear of the bed). I swapped to glass and all is clear too.

From my measurements I calculate that there is a hard coded dimension of 2.30 mm for the distance of the probe switch point to the bed Z0 plane set on homing.

z home

The nozzle must therefore be at least 2.30 mm above this switch point to avoid hitting the bed (but not higher that the body of the sensor to avoid contacting the print)

Then when you set the Z-Height to a piece of paper the Z-offset is stored in the settings / sensor z offset field

z height

as shown here -0.88

IMG_20201124_231023

I had expected the sensor switch height to be something that can be set in the settings.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.