No compensation for bed mesh?

My first layer has noticeable thick and thin spots. Grid has been changed to 4x4, frame was checked for square and perpendicular.

You can see at the back side the nozzle is pretty much just rubbing on the bed:
IMG_20200311_225504

G29 output:

Bilinear Leveling Grid:
      0      1      2      3
 0 -0.045 -0.150 -0.350 -0.375
 1 +0.185 +0.058 -0.143 -0.273
 2 +0.360 +0.170 -0.058 -0.155
 3 +0.640 +0.408 +0.095 -0.063

running version 4.0.6
Maker Select Plus
BLTouch 3

Startup gcode

G21 ; metric values
G90 ; absolute positioning
M82 ; set extruder to absolute mode
M107 ; start with the fan off
M140 S{material_bed_temperature_layer_0} ; Set bed temperature (no wait)
G28 X Y F6000 ; move X/Y to min endstops
G28 Z F1200 ; move Z to min endstops ; raise the nozzle
G28 X Y F6000 ; move X/Y to min endstops
M190 S{material_bed_temperature_layer_0} ; wait for bed temperature to reach target
M104 S{material_print_temperature_layer_0} T0 ; set extruder temperature (no wait)
G29 ; auto-leveling
G28 X Y F6000 ; move X/Y to min endstops, may disable bed leveling
M420 S1 ; enable bed leveling compensation
M109 S{material_print_temperature_layer_0} T0 ; set extruder temperature and wait
M300 P200 ; beep to indicate that the temp is reached
G1 X5 Y5 F3000;
G0 Z0.3 ; Drop to bed
G92 E0 ; zero the extruded length
G1 X55 E20 F350 ; Extrude 20mm of filament in a 4cm line
G1 X100 F4000 ; Quickly wipe away from the filament line
G92 E0 ; zero the extruded length
M117 Printing from Cura...; message

This is because your hotend is not parallel to the z axis. There probably a small torsion of you two x axis rodes.

hrm, I would have thought the mesh would detect and compensate for that

This is geometrically not possible. The mesh leveling is able to compensate the tilt of the bed, not problems when your nozzle is not moving parallel to x-y plane.