Min temp check is too high

Hi all.
I have a Cocoon Create Touch. I’ve just upgraded to 4.0.2, and activated the thermal runaway check. I’ve done a few prints, and it’s been really good.
This morning I tried to preheat and I got an error E1 saying that the minimum temp had been exceeded. My extruder was showing 4C. The actual room temp was 12C. Turning off the thermal runaway check did not help - it still would not heat. After checking connections, etc, I decided to gently warm the extruder with a heat gun. I got it up to about 10C, then it was OK, the error message did not occur and it heated normally. I let it cool back down again, and the problem re-appeared. Obviously, the temperature reading at room temp is inaccurate, but it still should let you heat!

Suggestions please…

Probably your thermistor is defective and you need to change it.

Ok, I’ve ordered a new thermistor.

But why does the printer complain about the temperature being too low? Or is it saying that the inside of a house could not be at 4C, so the sensor is defective?

Another question… how accurate are the thermisors anyway?

Thanks

When a thermistor fails, it often indicates low temperatures. As a consequence, the printer will heat the hotend (or bed) more. Since the temperature stays low (as seen by the printer), it will continue to heat, …
As a consequence, it may start to burn and in the worst case, your house will burn also!

If the temperature of your environment is low, yes it will not work.

The accuracy of a thermistor is dependent of many factors, like the manufacturer. But it is under 1 degree C.

Well, I replaced the thermistor.

The problem remains. The head temp reads 3C when the room temp is 13C. The thermal protection won’t allow preheating - same error as previously. When I turn off the thermal protection, the preheat temp is able to be started, but the heating does not occur. When I warm the head (with a heat gun) until the reading gets to about 10C, the problem goes away and the head heats normally.

Is there a way of “calibrating” the temp reading? Or lowering the error check point?

Any other suggestions?

Further to the above:

At power-up the room temp is 13C. The bed shows 8C and the extruder 4C. It won’t preheat,

If I leave the printer powered up for a while until the screen dims, both the temperatures suddenly show 11C. As soon as I touch the screen, the displayed temps return to 4c and 8C.

What is happening?

There are different kind of thermistor, each with a corresponding table in Marlin to map the raw value from the input pin to a temperature. So if you replace the thermistor with another kind, the temperature displayed will be wrong. What kind of thermistor have you installed? Do you have a link? Do you already change the thermistor in the past?

What is happening?

I do not know. Is your printer connected by USB to your computer? In this case, you can have more information using a terminal (or OctoPrint terminal tab, or any equivalent).

In this version, you have the possibility to disable the Thermal Runaway check. But I think you have some hardware problem somewhere so I do not recommend to do so and instead, searching for the root cause.

I ordered the OEM part here:


I have never changed the thermistor before.

I can connect via USB. I am running Ubuntu, so I need to know how to connect using a terminal.

From what you’ve said, it sounds to me that the Marlin software is detecting the wrong type of thermistor.

The temperature change when the screen dims sounds like a bug in the program.

Thanks.

Marlin does not “detect” the thermistor. This is hardcode during the compilation. The printer you have is an exact clone of Wanhao i3 Plus and the thermistor you bought seems to be the right model. So this is probably not the cause of your problem.

You are the only one to report this so, unless someone else report the same problem, I think it is a problem in your printer.

Can you go in Tuning / Diagnosis and look at the values on the top (under PF1 and PK6). These are the raw values read directly from the input pins without any interpretation. Can you let the screen dim and see if the value change significantly?

Screen after power-on. The room temp was 11C, but the printer shows 0C and 4C:

Readings before screen dims:

Readings after the screen dims:

The readings in the above screen fluctuate a lot between 997 and 003 (for the extruder) and between 998 and 004 (for the bed). That doesn’t happen when the screen is not dimmed.

Note that this heating issue has only been a problem since I switched from the standard printer program to ADVi3++.

Of course since there is no Thermal Runaway protection in the firmware of Wanhao.

The values (all of them) are abnormal and I think that some part of your printer is broken. Perhaps the PSU, perhaps the mainboard. I even think that your printer is dangerous.

Is it possible that this is only a communication issue with the screen? The reason I ask is that I removed the screen to install an external screen mount (the one you recommended). Maybe I failed to reconnect the screen cable properly?

If that’s not the problem, is there a diagnosis procedure I can use to determine what the problem is?

Thanks

No. The values displayed can’t be explained by a communication problem. But could be an electrical problem, a shortcut somewhere, perhaps with the cable to the LCD panel.

OK, well I’ve pulled the printer apart looking for shorts, loose connections, etc. but I couldn’t find anything.

I cross-checked the displayed temps against other thermometers I have (IR, thermocouple, Telltru), and as best as I can measure the bed is within 5C of what is displayed, and the extruder is within 10C of what is displayed (this is at operating temps, not room temp).

On that basis, I think the thermistors are OK.

One other interesting item I have discovered is that that the bed is having difficulty in maintaining 105C for ABS. It’s fine on PLA, because the temp is much lower. I would never have seen this with the OEM software. When the cooling fan cuts in after the first layer, the bed temp starts to drop slowly and the Thermal Protection cuts in after a while. I had to put up draught shields around the printer, increase the I component of the bed PID, and reduce the fan speed to about 40%. I don’t know if this is a characteristic of the I3 clones, or if it helps diagnose what my printer’s problem is.

Is there any diagnostic procedure?

Thanks

The precision of the thermistors is far better than that (like 1%). Since you have change the thermistor of the hotend, yes, probably this is not the problem.

No.

Looks like again an electrical problem. Maybe your PSU is not providing enough power.

Of the printer hardware? I do not think so.

I checked the PSU and the connections to the motherboard. With both heaters running from cold (i.e. no PCM) it showed 24.0V at the power supply output, and 23.8V at the connections on the hotbed itself.

So, I think the PSU is OK.

To check the bed’s heating profile, I took the following readings as it heated up:
0 min - 27C
1 min - 44C
2 min - 59C
3 min - 70C
4 min - 79C
Does this seem normal?

Thanks in advance…

Measuring the voltage of the PSU does not indicate that it is OK. For me, it looks like it is not able to provide enough power. The fact that things are changing when the LCD is dimmed or not may be related: the dimmed LCD consumes less power.

For the list of temperature, it looks like it is slow to heat. But frankly, I am not sure. My ambiant temperature is around 25°C these days so I can’t compare.

There is a switch on the back of the PSU to select 230 or 115V. Is it in the right position for your country?

Something you can also do to eliminate ADVi3++ as a possible cause of your problem (because I think it is not related, but who knows): flash a stock firmware. I have a small collection of firmwares here:

If your Cocoon has the model number HE161192, it is a exact clone of the Wanhao i3 Plus, so you can also flash the firmware from their web site (I3plus):

http://www.wanhao3dprinter.com/FAQ/ShowArticle.asp?ArticleID=79

OK.

I reloaded the Cocoon software and I got the correct temps showing on the screen. But this was when it was powered from the PC via the USB cable. When I tried to run from the main power supply, I got the incorrect temperatures!

Therefore I conclude that 5V supply is faulty.

I re-installed the 4.0.2 ADVi3++ and I get the same result.

Now I need to find out how the 5V is supplied…

Update:

I thought of a workaround: I’ll run the processor off an external 5V supply via the USB connection, and just use the main PSU for heating. NO… as soon as you turn on the main supply it overrides the USB input.

The voltage across the hotend thermistor is 4.83V with the internal power supply and 4.95V with the USB supply. The USB power supply gives the correct temperature readings (at room temp).

It may have been always like that, and it’s only the ADVi3++ that causes an error because of the thermal protection. I don’t know.

It sounds like a new motherboard is needed, as the 5V supply is buried in it somewhere. Aaagh!

And now I find the suppliers in Australia are out-of-stock.

So, in order to create a work-around the next questions are:
a) can I adjust the 5V?
b) can I re-calibrate the look-up-table for resistance/temperatures?
c) can I change the reference voltage in the that the system uses to calculate the temp?

Thanks

The PSU is providing 24V to many parts of the printer (bed, hotend, fans) and 5V for the “Arduino” part (the mainboard is more or less the equivalent of an Arduino Mega 2560). The Arduino part can be powered by the USB cable. There is an automatic switch between the power provided by the USB and the PSU as you guess correctly.

No

Why do you want to do that? You have the right thermistor and thus thermistor table. You can change the table, but is far from trivial to build your own table.

This is performed by the table.

It looks like you want to fix the symptoms of the problem, not the problem itself. And I am not sure, but it looks that the problem comes from your PSU, not the Mainboard.