Mainboard replacement options? Stepper driver failed

I have an Aldi Cocoon Create Touch (5.1 version mainboard)
and a BLTouch3

Looks like the stepper driver has died for the extruder so I’m looking at replacing the mainboard.
I don’t really want to use an external stepper driver because that requires compiling every time I update.

So if I’m going to swap out the mainboard, should I just get another 5.1 board OR should I take the opportunity to update the mainboard. If so, what do you all recommend?

What are your thoughts?

Cheers, Marty

If you change the board, it will be a different printer and you will have to adapt yourself the firmware. But you said that you do not want that. So what do you have in your mind? Replace by a 5.4 board ? But it is not an upgrade of the 5.1. It is a different board with hardware differences (such as a bigger connector, …)

1 Like

Ok. Thanks… I think it’s less problems to just swap the board for the same.
Also, if a driver chip blows in the future, I’ve got three good ones on the old board I can surface mount swap over too.

Thanks for that advice.

Marty

If you have (micro-)soldering skills, you can change the drivers on your existing board. It is better to check yourself, but in general the drivers are Allegro Microsystems A4988ET.

Thanks for that. Il’l get a few and try my hand at fixing my old board. Always good to have a spare.
I got a replacement v5.1 mainboard from cocoon (Aldi) in Australia - It was $150 but that included shipping it to me and it arrived 2 days after I ordered it.

NOTE TO ANYONE IN AUSTRALIA WHO NEEDS A NEW MAINBOARD: Contact https://support.cocoonproducts.com.au/ and you’ll be back up and printing with in a few days!

The other option was a mainboard at about $100 AUD shipped from Wanhao China by AliExpress. I’d be lucky if that arrived sooner than 2 months so the extra $50 was money well spent. :rofl:

I will order some of those driver chips though - they are about $2 each and it’s less stress on me and the chip to just solder on a new one than risk damaging one by transplanting it.

Thanks so much for your help and your awesome firmware. I’ve been a subscriber since day one! :kissing_heart: :heart: :heart: :heart: :heart:

Marty

(Post edited to correct version number of main board)

I think you mean 5.1. Isn’t it?

1 Like

Yes, 5.1 I’ll edit that post so not to confuse people. :+1:t3:

hi @Martin_Dolan

Maybe this will help…

Hello Martin,
I was wondering did your stepper motor move at all? I just upgraded my firmware and added a hemera hotend and now my stepper motor only moves back and forth. I was thinking of replacing the board behind the carriage, and the ribbon connector to see if that helps. It was working fine until I decided to do all these changes at once. The stepper motor also works on the z axis cable.

Which stepper has failed?
a few things on steppers…

  • never unplug them while the system is powered on
  • you shouldn’t move them by hand (like slide the the head from side to side) because motors can run from electricity or also make it. - a motor and a generator is the same thing the only difference is what is making it turn. so if you move it quickly yourself the power it makes can blow up the driver
  • some of those stepper motors are wired up differently - I had to switch a couple of wires to get my new stepper motor on the extruder to work.

usually when the driver is dead the stepper will just shudder back and forth. Can also do this if the wiring is wrong.

do you have a multimeter ? I can help you with some more info. You want to get the wiring right before you power it on because if it’s wrong that can also kill the stepper driver.

There is not a lot on the board behind the print head, its basically a breakout board or adaptor for the different plugs. Not a lot to go wrong. no chips or anything that can go wrong really.

Let me know if you have a multimeter. if you haven’t I suggest you go buy one. It’s a good investment. Bloody handy for all sorts of stuff.

This board has some conception problems and it can have shorts. Happened to some people in the past.

It is the extruder stepper that I am having trouble with. I tested it by plunging it into the Z axis spot and it worked perfectly when moving up and down with the Z controls. That is why I’m leaning towards the board behind the extruder or ribbon cable, I dont see any visible defects.

I do have a multimeter but when I tried it last week it isn’t reading anything… Im going to go get another one tomorrow so that I can test out the components to see what needs to be replaced.

I am hoping it is what you mentioned that maybe the wiring needs to be rearranged in order to get it working properly.

If you have any advise for testing with the multimeter I will give it a shot. Thanks again.

Sounds like it could be the stepper driver on the board.
Please don’t go randomly changing the wires around as that is likely to blow up the stepper driver.

When you have the multimeter, first check each wire from the motor plug to the main board for continuity. That way you’ll know if it’s a broken wire.
(do this while it’s unplugged from power and also any usb device like octoprint server etc.)

When you’ve done that, and made sure there is no issue with the wiring, we need to check the voltage that the stepper driver is outputting…