Leveling Issue with BL Touch 3.1 on Monoprice Maker Select Plus

OK so I installed the BL touch without issues and I’m running 4.0.3. I setup the Z probe and it does the automatic leveling routine just fine. But when it starts to print in some spots on the board it prints just fine but other spots the head is to low or to high and I can’t seem to find the sweet spot. I’m not sure what I’m doing wrong, so any help would be great. I did go through the manual leveling and setup all spots with a piece of paper and also made sure the x axis was level all the way across and then when the print starts and auto-levels and prints some spots are too high and some are too low. and the print will either not stick or the extruder will start clicking because it’s to close to the bed. It’s like the auto level is not working right or the settings are messed up some where. Not to familiar with how the auto level works but I would think it would compensate for the low and the highs if the bed was off. Any help would be appreciated.

I had this problem and fixed it by modifying my print start code.
after G29 add M420 S1 to enable the use of leveling data.
here is my startup code ‘BED’ and ‘TEMP’ get replaced with temperature values by my slicer

G21                                             ; Set metric values
G90                                             ; Set absolute positioning
M82                                             ; Set extruder to absolute mode
G28 X0 Y0                                       ; Move X/Y to min endstops
G28 Z0                                          ; Move Z to min endstops
G1 Z20                                          ; Raise the head
M140 S'BED'                                     ; heat bed
G29                                             ; Auto-leveling
M420 S1                                         ; Enasble Auto Leveling
G1 X0 Y0 F3000                                  ; Go to home (without homing: it would disable compensation)
M104 S'TEMP'                                    ; heat extruder
M109 S'TEMP'                                    ; wait for extruder to heat
M190 S'BED'                                     ; wait for bed to heat
G92 E0                                          ; Zero the extruded length
M300                                            ; Play tone

OK, I tried just adding the M420 S1; Enable Auto Leveling but that did not work. So I just copied and pasted your Gcode into my Simplify 3d Gcode and it started to auto level and skipped home ( the BL Touch was heading down on home and then came back up Extruding a bunch of plastic, and went through the rest of the auto leveling just fine.) Then when it started to print the test squares the extruder did a dip and came back up ,extruded plastic in the air and then came back down went to the middle of the bed and printed a test square which was printing to high and then went to the right bottom corner and printed to close to the bed. So that was a failed print also. I just dont get why this thing is not leveling properly. It must be saving the Gcode because it skipped home when auto leveling so it has to be saving the code or it would not have done that. But the squares it printed where also off so the auto level did not work as well. On a side note like I said when it goes through the auto level process it works just fine and I get no errors or problems until it begins to print, then the printer extrudes plastic to high or to low on spots of the heat bead.

Until I figure out what is going on is there a way to disable the bl touch from scanning the board so I can manually do the board. I have a lot of prints to do. Thank you

So I considered its may be the G code I’m entering into my slicer that could be the issue. So I copied what was suggested for Simplify 3d and Cura but that didn’t seem to help me either. I just don’t get it. Everything seems to work but when it auto level’s it seems like it doesn’t compensate for the auto-level and my prints on the mesh are too far down on the bed or too far up on different places on the bed. It just frustrating me I don’t get why this is not working.

This is no more necessary as automatic bed leveling is reenabled automatically after G29.

I am having what believe is the same problem with my Monoprice Maker Select Plus. My back left corner is consistently measuring as a high spot after an auto bed level. But when the print starts the print head does not get close enough to the bed for the filament to stick. I believe the issue may be because it is hitting my z-stop. But when I remove and unplug my z-stop my printer tries to home before leveling and it pushes down until i cut the power because it is trying to find the z-stop. Please advise

Thanks

WN

@wnelson14 You are using ADVi3++ version 3, right? Version 4 does not use the z endstop, version 3 does.

I made a short video of the bl touch doing a level with the results. Do you see anything wrong that Im doing. Thanks https://www.youtube.com/watch?v=D0Wx37OtTLY

And what are you doing after that?

I hit the check-mark by Grid. Then I go into simplify 3d and print it. Here is what is the code in Simplify 3d is.

G21 ; metric values
G90 ; absolute positioning
M82 ; set extruder to absolute mode
M107 ; start with the fan off
M140 S[bed0_temperature] ; Set bed temperature (no wait)
G28 X Y F6000 ; move X/Y to min endstops
G28 Z F1200 ; move Z to min endstops ; raise the nozzle
G28 X Y F6000 ; move X/Y to min endstops
M190 S[bed0_temperature] ; wait for bed temperature to reach target
M104 S[extruder0_temperature] T0 ; set extruder temperature (no wait)
G29 ; auto-leveling
G28 X Y F6000 ; move X/Y to min endstops
may disable bed leveling
M420 S1 ; enable bed leveling compensation
M109 S[extruder0_temperature] T0 ; set extruder temperature and wait
M300 P200 ; beep to indicate that the temp is reached
G1 Z15 F1200 ; raise to have room
G92 E0 ; zero the extruded length
G1 F140 E30 ; extrude 3mm of feed stock
G4 S2 ; Wait for 2 seconds
G92 E0 ; zero the extruded length
G1 X5 Y5 F2000; Move a little over the bed
M117 Printing from Simplify3D...; message

And the setup is
image

having the same issue using this start Gcode anyone have any ideas what’s happening

G21 ; metric values
G90 ; absolute positioning
M82 ; set extruder to absolute mode
M107 ; start with the fan off
M140 S{material_bed_temperature_layer_0} ; Set bed temperature (no wait)
G28 X Y F6000 ; move X/Y to min endstops
G28 Z F1200 ; move Z to min endstops ; raise the nozzle
G28 X Y F6000 ; move X/Y to min endstops
M190 S{material_bed_temperature_layer_0} ; wait for bed temperature to reach target
M104 S{material_print_temperature_layer_0} T0 ; set extruder temperature (no wait)
G29 ; auto-leveling
G28 X Y F6000 ; move X/Y to min endstops, may disable bed leveling
M420 S1 ; enable bed leveling compensation
M109 S{material_print_temperature_layer_0} T0 ; set extruder temperature and wait
M300 P200 ; beep to indicate that the temp is reached
G1 Z15 F1200 ; raise to have room
G92 E0 ; zero the extruded length
G1 F140 E30 ; extrude 3mm of feed stock
G4 S2 ; Wait for 2 seconds
G92 E0 ; zero the extruded length
M117 Printing from Cura...; message

After painfully messing around and reading and swapping parts out on the printer for why the bed leveling was not working i finally found my solution to the problem. So here is what happened. I kept trying to figure out why my printer was not keeping the bed leveling after it would go through the process of auto leveling before printing. So after doing the 30th test my extruder stopped working correctly, it would just click and click but no filament would come out. Now most people kept telling me it was a nozzle clog, but it was not, I checked. So someone told me the stepper motor was shot, so I replaced it. Same thing it just kept clicking. So then I changed out the motherboard with a new motherboard (Same Model) because someone told me the stepper motor driver was probably shot on the motherboard. Well after replacing the board the extruder still kept clicking. So now I was confused and now I figured there must be a wiring problem. Well come to find out my 16 pin ribbon cable that runs from the extruder to the board had a short in it. And apparently this cable runs almost everything on the machine. So after I replaced the ribbon cable and put everything back together and leveled the x,y, and z the best I could. I setup my z height and did an auto level. Now to my surprise the auto leveled worked completely different than all the other times I did it ran it. It went through each coordinate like it usually does, but a lot slower. Like it was thinking about it this time. ( Now with a bad ribbon cable when it ran through the process it went about 10 seconds faster. Now being I have never seen the way it should auto-level I though that process was correct, but no it was not) Anyways after it did the initial bed level with the new ribbon cable and did a bed level print test, it printed perfectly on all corners. So I had a bad ribbon cable to begin with, I just wanted to point out that when it goes through the auto level on each coordinate and it drops down and goes up it shouldn’t be a steady speed. It should pause for a second after each check, like it saving the setting each time. I am not sure how it all works but I wanted to put my experience out there. So if you Auto Level doesn’t seem to be saving the mesh and it is off, it could be the ribbon cable. That’s what mine was. I thank everyone for the help. Hopefully this will help someone at some point. Thanks.