LCD not flashing correctly? Text missing

I have tried to re flash to the latest version from 4.02 but the lcd display either freezes on the boot animation or when it boots no text is displayed instead the text is appearing as coloured shapes I have flashed the main board and also completed the eeprom clearing just in case but i am stumped

Please choose a meaningful title (as required by the rules of this forum). Otherwise, it provides no help for other people that may have a similar problem.

What does it mean exactly?

Can you post a picture?

Sure when I get home I will post a picture

And when I boot the printer the lcd screen will freeze on the benchy animation

Most problems with flashing the LCD are due to using an SD card that is larger than 8GB, or by the card being formatted in a way that causes errors when read by the LCD. I would recommend trying an 8GB or smaller SD card if you are using one that is larger.

If you’re already using a smaller SD card, you can also try re-formatting it following the directions in the “LCD Panel - Manual Copy” section here https://community.advi3pp.com/t/alternative-ways-to-flash/30 instead of just flashing with Etcher, or formatting it before flashing the image using Etcher. I’ve had SD cards that for some reason fail to properly update the LCD until after I re-format and re-image them, so I would give that a shot if you’re still having issues.

image

This is the display I will re format the SD (it’s 8gb) I am also going to attempt to flash to a previous version

This has worked thank you :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.