Issues with Bed indicated T° going down after around 20’ printing

Hi,

I use a Balco i3 with 5.1 board and the 4.0.6 firmware. with BLTouch 3v1

It worked very well for a time. I like the FWare.

I decided to adjust again my Bed PID since I use another glass plate on top . Has then worked fine too. But now after maybe 20 minutes printing on a 100°C Bed T°, the indicated T° on screen slowly goes down to 96 and initiates then a stop because of a too big difference between set and resulting T°. It is proved that the T° runaway detection works.

New external 25A Mosfet : no difference

New original bed and thermistor : no difference

The PWM signal on normal behavior at the beginning varies from 45 to 100% full load and keeps the T° stable at 100+0-1°C which is perfect . If I had used a scope from the beginning , I would not have bought a new bed and ….

When the indicated T° drops , I can see the PWM ( and by thus also the MosFET current monitored on a Scope meter ) going to 100% load. Of course , the real bed T° goes to Max…. At indicated 96°C : failure.

The thing I have difficulties to understand is the fact that preheating the bed to 100°C works perfectly for hours and the PWM is perfectly working fine… until I decide to print.

I tried Cura 4.6, & Prusa Slicer 2.2.0 with and without PID settings in the GCode…

What do I miss somewhere….?

Thanks in advance

Best regards

As this is not related to ADVi3++ but to your hardware, please do not post here but in “Printers Stuff”. I have moved your message.

Your problem looks like a power issue. Maybe your PSU is faulty.

Hello,

Thank you for answering.

As willing to be on the safe side, I exchanged already - long before the troubles - the PS-unit by a MeanWell 350W capable of delivering 14.6A. Almost 3 times the MosFET is asking

During the whole process , I monitored the PS Voltage which remained on 24V with a voltmeter.

So , I guess I will have to downgrade with the original PSU to try…

:wink:

So looks like something else.

Maybe silly, but are you sure that your thermistor is not moving during print? Just a slight movement and the seen temperature will drop.

I tought that too. I replaced it on the old plate again with new Kapton tape and a rubber between to have a kind of spring pushing the Thermistor against the plate . That didn’t do the trick.
The new plate i got was prewired with a thermistor already taped on it : exactly the same behaviour.

The only differences between the plates are the PID values :
PID old plate : 491 ; 84 ; 59
PID new plate : 164 ; 8 ; 152
Big differences between old and new.

Repeating the PID procedure on the new plate does vary the values in my point of view a lot.
P : 164 145 157
I : 8.4 7.7 8.2
D : 152 31 98

It all does look like a bad contact but i did remove the soldered tips and replaced them with clamp bushes . still the same .

One can think that there might be a bad contact on the main board also. But heating the plate during hours and hours without printing does not trouble the indicated T° and the PWM at all…
Having a bad contact on the MBoard would make the fault appear directly when starting with printing. No , it is always after 20 -25 min. printing …

Perhaps for some reasons, your printer/bed does not like Bed PID. In the stock firmware (if I remember well), PID for the bed is not activated (ie. PIDTEMPBED is not defined). Worse a try to desactivate it.

Hum,…

I did notice that in the manual settings of the PID, the first is 100°C and has PID 164, 8.4 , 152.
The second setting is for the 50°C and has a PID 181, 81, 457
The third is also 50°C and PID 333, 9, 432

I would be rather confused too if i had to regulate the T° myself :wink:

Since i can not change the set PID T° , i will set the 2nd and the 3rd manually on the same values as the first. I have a mechanical finger pushing on the screen while writing this …

Now I’m really curious.

Testing in maybe an hour.

:wink:

Not sure to understand your last message…

If PIDTEMPBED, the printer will regulate the T° itself. It is just using bang-bang instead of PID.

There’s something wrong here, like a mix of temperatures for the Hotend and the Bed.

Results of a few things :
-Changing the PID values in such way that the sw could not struggle in extrapolating values because the 3 settings had the same values corresponding to the 100°C setting did not solve the problem.

-Did a factory reset and set the main parameters values like they have been changed according a lot of testprints except those regarding the T°.: Test print failed the same way as usual. : 25minutes 96°C ,
PWM full load, working fine.

Conclusion ; it must be a hardware failure on the MainPCB.
In the next days, i will redo every solder pad on the PCB ( specially the ones regarding the Feedback Bed T° ) and see if that helps

If not , i guess a new PCB…

Thanks a lot for your help today , Sebastien.
I will keep you informed in a few days
Have a nice evening.
:wink: