Issues after sanding the aluminum bed

I’ve got a

  • Wanhao i3 Plus V2 from Microcenter (PowerSpec Branded).
  • Genuine BLTouch v3.1
  • ADVi3++ v4.0.6

I noticed that my bed was a bit warped, so I did a ton of sanding and a little shimming before installing a wambam magnetic surface.

The problem I’m having is that I can level the bed very accurately using a paper feeler. I follow that up with Auto Bed Leveling routine, and I get some numbers. Every time I print, it’s like the ABL is overcompensating for the measured values. That or the values are flat wrong.

Things I’ve checked and rechecked:
x-axis alignment - make sure they are parallel, turn z-axis lead screws until alignment sticks are tight.
manual bed leveling - make sure paper feeler has very close to the same amount of friction at each manual point.
extruder e-steps - tuned it multiple times, getting very clean and consistent extrusion
z-height offset - I can get a perfect 1 layer square in the middle.

I’m at my whits end. I’ve been driving myself crazy for two weeks trying to figure this out. Today I ran an experiment, I tried a print that I sliced with just 1 layer as an infill pattern only. I printed it, ran ABL rutine, printed it again. The results were shocking.

No ABL:
image
ABL Output:
image
With ABL:
image

You can see, it’s as if the ABL is compensating too much. I suspect this is more to do with the measured values than it is with the firmware. The left side is so close that I heard the extruder skipping, the right side is so far away that it doesn’t stick at all.

Any help, ideas, or encouragement is appreciated.

Just some updates.
I indeed got the correct firmware with BLTouch3.

I’ve ordered a borosilicate glass bed to try out. If that solves my issue I’ll be installing a new whambam magnet on that. Theoretically this will guarantee flatness and allow me to continue using the flex plates.

Checking the surface of the bed with a straight edge and I can definitely still see some gaps. I thought I’d sanded them all out, but I guess there is plenty of room for error in this. I’m not certain which layer the gaps are introduced, but they exist. My advice for anyone thinking about sanding their aluminum plate is DONT. It’s a waste of your time, and you can easily solve the problem with $20 and some patience.

I’ll report back when I have the new bed tested out. Hopefully the glass is flat, and I get clean prints.

This is not really related to the firmware. So I am moving your post in another category. Your title is also odd.

No worries. It’s hard to know where to post sometimes.

With the glass bed, I’m still getting the same issues. I think this post may be very related to what I’m experiencing.

I’ll be going through squaring and alignment steps. I’m very suspicious of my X-axis rods.

No problem. Questions directly related to ADVi3++ in Get Help, posts related to modifications of the printer in Mods, everything else in Printers Stuff.

I have changed the title for something more related to your post.

Do not assume that glass is flat. It is not. Automatic bed leveling should compensate for that. It is very likely that you have issues with your x-axis. Look at:
https://community.advi3pp.com/t/the-left-side-is-too-close-the-right-side-is-too-high-or-the-contrary/100

Especially the part “Twist on the X axis”.

Thank You!

I’ve also determined it’s a problem with the X-axis. I don’t quite know how to fix it. I spent some time trying to square the XZ assembly on either side with the frame. While it did change my ABL results a little, it didn’t work.

I slept on it, and I think I’ll need a way to align the rods to eachother instead. If I figure out a good way to do it consistently, I’ll be sure to let everyone know.

Yes this is difficult. This is way the future version 5 will integrate a tool to help compensate this kind of issue.

I’ve solved the problem.

I found the X-Axis was way off on the left side (the one with x-axis motor). I tried a lot of things to figure out what the easiest solution was, and I’ve settled on using a square and adjusting the 4 large gantry screws. When you unscrew those you get the most flex in the frame, and the most amount of adjustment.

I tried a number of other things messing around with rod mounts and the smaller M3 mounting screws. These options didn’t offer any adjustment, as most of these screws will flush up against the frame. You’d have to bend the frame to make it work.

How to adjust for a twisted x-axis

Tools

  • 4mm Hex Driver/Wrench/Key
  • Square (I used a small 6-inch machinist square)

Prepare the printer

  1. Heat the extruder and remove filament.
  2. Home axis
  3. Let the printer cool off
  4. Turn the printer off, unplug it
  5. Unplug the z-axis steppers for easier access to M6 screws

Adjust

Check the x-axis rods against the y-axis frame

20201214_191654

Use the square against the frame to check if the rods are in line with each other. You may have to use the square on both sides of the rods to determine if there is a problem. You can make this measurement 4-ways.

Adjust the worst side first

  1. Loosen the two large M6 screws (the ones that attach the gantry to the bed)
    20201214_191406_screw
  2. Use the square to push the rods into alignment, apply force to the corner of the square until both rods are touching it. Be careful not to bend your rods.
    PUSH
  3. Tighten screws while applying enough force to maintain rod alignment.
  4. Recheck alignment of both sides
  5. Repeat on other side if necessary

Notes

  • Your gantry may be bent. Even though you’ve squared the corners, it’s possible to have misaligned x-axis rods.
  • z-braces may help in correcting this. Applying torque to the top section of the frame, you may be able to align the x-axis. I would recommend loosening the base screws before attempting this. Your z-braces may not be the same distance after this. This could be putting a lot of material stress into your machine, and it could warp over time.
  • A flat and even surface, like a countertop or machined table, can help to square the bottoms of the gantry. However, on my machine when the bottoms of the gantry were flush, the axis was still misaligned. I favored axis alignment over frame alignment.
  • You may be able to tell by the Auto Bed Leveling which way it’s twisted. Negative numbers mean the top rod on that side is tilted backward (away for the bltouch). Positive numbers mean the top rod is tilted forward (toward the bltouch). You still want to double check this with a square. On my machine, only the motor side of the x-axis was off.

Results

Before Alignment

20201213_205703

After Alignment

20201214_204042

This what I explained in the Troubleshooting guide. Or I do not see something?

The troubleshooting guide says to align the z frame (gantry) with the xy (bed) frame. Here I’m aligning the x rods with the xy frame instead. Aligning the frame wont help if it is bent or warped for some reason. The alignment on the axis rods are arguably more critical.

I’m not using z-braces so I didn’t have a way to force anything into alignment.

Also, adjusting the rod holders themselves didn’t help me at all. Every time I tightened them back down, they would just realign with the frame, and I would have a twisted x-axis again.

Because I’m not the only one with the problem, I decided to write some instructions on what I did. You can do what you want with them, I just wanted to explain in more detail what worked for me.

And I want to understand it precisely because, as you said, it is a common problem. So I can modify my instructions to incorporate yours.

I hope I explained it well enough. If you need me to elaborate more I can. The crux of it is aligning the rods, not the frame.

I was thinking about this more. It occurs to me that moving the BLtouch to be in the same x-plane as the nozzle could also resolve this issue. If the nozzle and sensor are parallel to the x rods, then any twist should affect both equally.

I’m thinking of designing a BLTouch mount that does just that.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.