Initial ramp over shoots desired temp by 20+C

Since I have updated to the newest v4.0.3 my hotend overshoots the desired temperature every time now.
I tried to run auto tune, but it fails when it exceeds the targets by 10 to 20C. I love that is ramps super fast and if you give it some time it stabilizes very well.

I tried to change the settings from OctoPrint, both through the GUI and the terminal issuing direct commands. It doesn’t seem to have any affect.

I finally started to make the changes from the printer settings manually, but it’s very slow going, since the +/- only increment by 0.01 (holding it down doesn’t make it go faster :frowning: ) . Now I’m trying to manually tune it but I’m not seeing any changes. Set it to 200C and it will hit 227C before it starts coming back down of the initial ramp. Once it stabilizes it doesn’t look to bad.

I decided to debug the issue. Here is my log of actions I kept while making changes.

Sorry for the length. Hopefully you can follow my notes as I made changes.
If I tried to change values from the OctoPrint terminal I copy/pasted the commands
into the log. I only logged changes as I went, so from top (oldest/start) to bottom
(newest/end/stopped) is the logical progression. With all changes being accumulative.

I’m not sure what the problem is, but changing my PID settings for my extruder doesn’t work.

========================================================
Original starting settings as viewed from the
printers PID settings screen.
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #1 Ext 20.01 0.01 180.01
PID #2 Ext 22.02 2.02 188.02
PID #3 Ext 23.03 1.03 189.03

PID #1 Bed 178.01 30.01 199.01
PID #2 Bed 1.02 61.02 1.02
PID #3 Bed 0.03 59.03 1.03

Fresh reboot of printer. Before shutdown selected
PID #2 settings with checkbox. Went into the screen again
to view, went to PID #3, but used the back button to leave.
After both issued M503, here is the results:
Recv: echo: M301 P20.01 I0.06 D29.49
Recv: echo: M304 P0.03 I59.03 D1.03

Went to settings on printer, selected PID #1 using the
checkmark in the right corner. M503 results:
Recv: echo: M301 P20.01 I0.06 D29.49
Recv: echo: M304 P178.01 I30.01 D199.01

Went to settings on printer, selected PID #2 using
checkmark. M503 results.
Recv: echo: M301 P22.02 I12.33 D30.81
Recv: echo: M304 P178.01 I30.01 D199.01

Went to settings on printer, viewed PID #3, but
used the back arrow in the left corner. M503 results:
Recv: echo: M301 P22.02 I12.33 D30.81
Recv: echo: M304 P178.01 I30.01 D199.01

Rebooted printer. M503 results:
Recv: echo: M301 P22.02 I12.33 D30.81
Recv: echo: M304 P178.01 I30.01 D199.01

From OctoPrint Terminal, issued the following:
Send: M301 P22.44 I22.44 D22.44
Recv: echo: p:22.44 i:22.44 d:22.44
Recv: ok
Send: M304 P111.44 I11.44 D111.44
Recv: echo: p:111.44 i:11.44 d:111.44
Recv: ok
M503 results:
Recv: echo: M301 P22.44 I22.44 D22.44
Recv: echo: M304 P111.44 I11.44 D111.44

Viewed settings on machine, no change found.
Left the PID settings screen while viewing
PID #1, but used the back button.

Rebooted printer. M503 results:
Recv: echo: M301 P22.02 I12.33 D30.81
Recv: echo: M304 P178.01 I30.01 D199.01

Viewed settings on machine, no changes found.
Used the back button to leave the PID settings
screen. I noticed when I did that, the OctoPrint
Terminal would scroll. Looks like a M501 was issued.
No change in the M503 results.

From OctoPrint Terminal, issued the following:
Send: M301 P22.45 I22.45 D22.45
Recv: echo: p:22.45 i:22.45 d:22.45
Recv: ok
Send: M304 P111.45 I11.45 D111.45
Recv: echo: p:111.45 i:11.45 d:111.45
Recv: ok
Send: M500
Recv: echo:Settings Stored (776 bytes; crc 29720)
Recv: ok
M503 results:
Recv: echo: M301 P22.45 I22.45 D22.45
Recv: echo: M304 P111.45 I11.45 D111.45

Still no visible change from the printers
PID settings screen. Left on PID #1 using
the back button.

Rebooted printer. M503 results:
Recv: echo: M301 P22.45 I22.45 D22.45
Recv: echo: M304 P111.45 I11.45 D111.45

Tried to use the terminal to load and recheck
the results.
Send: M504
Recv: echo:EEPROM OK
Recv: ok
Send: M501
Recv: echo:PID settings:
Recv: echo: M301 P22.45 I22.45 D22.45
Recv: echo: M304 P111.45 I11.45 D111.45
Send: M503
Recv: echo: M301 P22.45 I22.45 D22.45
Recv: echo: M304 P111.45 I11.45 D111.45
Still no visuable change in the printer setting
on the printers screen.

Rebooted printer, settings on the screen are still
unchanged from the original numbers. The M503
still nows the values issued from the termial, which
doesn’t match anything on the machine screens.
Recv: echo: M301 P22.45 I22.45 D22.45
Recv: echo: M304 P111.45 I11.45 D111.45

Changing the settings on the machine settings screen.
These are the new values, only edited PID#1 group.
Used the check mark button to save settings.
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #1 Ext 20.11 0.11 180.11
I tried to go into the machine settings and clicked
save, check the M503 results from terminal. I did
this 3 times and same results as the last M503.

Selected PID #2 and cliked the checkmark. Didn’t
make any changes from it’s last setting.

PID #1 Bed 178.11 30.11 199.11

After checkmakr button was pushed saw the M500 message
pop up in the terminal.
Recv: echo:enqueueing “M500”

M503 results:
Recv: echo: M301 P20.11 I0.67 D29.51
Recv: echo: M304 P178.11 I30.11 D199.11

Went back to machine screen and selected PID #2,
using checkmark button. M503 resutls:
Recv: echo: M301 P22.02 I12.33 D30.81
Recv: echo: M304 P178.11 I30.11 D199.11

Changed the settings from the machine PID
screen. Select PID #2 and changed the values to
the following:
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #2 Ext 22.22 2.22 188.22
PID #2 Bed 1.22 61.22 1.22
Recv: echo:enqueueing “M500”

M503 results:
Recv: echo: M301 P22.22 I13.55 D30.84
Recv: echo: M304 P1.22 I61.22 D1.22

From the printer screen, selected PID #1
and saved changes.
Recv: echo:enqueueing “M500”

M503 results:
Recv: echo: M301 P20.11 I0.67 D29.51
Recv: echo: M304 P1.22 I61.22 D1.22

Rebooted printer.
M503 results:
Recv: echo: M301 P20.11 I0.67 D29.51
Recv: echo: M304 P1.22 I61.22 D1.22

On the printer selected PID #1 and changed
the settings to the following, and saved.
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #1 Ext 20.21 0.21 180.21
PID #1 Bed 178.21 30.21 199.21
Recv: echo:enqueueing “M500”

Noticed something really wierd with the
extruder Kp setting. While changing it from
20.11 to 20.21, it would go back to 20.20 if I
left the screen and came back (like if using
the arrows to view PID’s #2 or 3, or even just
selecting the bed and flipping back).
I was abile to get it to go to 20.21 by setting
it to 20.22.
If I was just viewing my prior changes at it was
at 20.21 and if I clicked save it would change it
to 20.20, even though I hadn’t made any changes.
This type of behavior only worked when the decimal
numbers were 21 or 22. If I selected .20 or .23 it
would still be that number after going back to the
screen. So if I set it to .22 and saved, it would
be .21 if I viewed it again. If when I viewed it,
it was .21 and saved it would be .20 when I viewed
it again. I didn’t test a large range of numbers,
only 20.19 to 20.24

M503 results:
Recv: echo: M301 P20.22 I1.28 D29.53
Recv: echo: M304 P178.21 I30.21 D199.21

Note the 20.22 above, that is was I had entered
when I pushed the save button, but on the machine
screen I see 20.21.

Changed the setting on the machine to:
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #1 Ext 20.23 0.22 180.22
PID #1 Bed 178.22 30.22 199.22
Recv: echo:enqueueing “M500”

M503 results:
Recv: echo: M301 P178.22 I184.45 D32.64
Recv: echo: M304 P178.22 I30.22 D199.22

Changed the setting on the machine to:
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #1 Ext 20.24 0.23 180.23
PID #1 Bed 178.23 30.23 199.23
Recv: echo:enqueueing “M500”

M503 results:
Recv: echo: M301 P20.24 I0.23 D180.23
Recv: echo: M304 P178.23 I30.23 D199.23

Wow, both the extrude and bed numbers match
between the machine and termial.

Rebooted printer.
M503 results:
Recv: echo: M301 P20.24 I1.40 D29.53
Recv: echo: M304 P178.23 I30.23 D199.23

Settings viewed from machine are unchanged
from last documented change.

Changing setting from machine again, new settings:
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #1 Ext 20.25 0.25 180.25
PID #1 Bed 178.25 30.25 199.25
Recv: echo:enqueueing “M500”

M503 results:
Recv: echo: M301 P20.25 I1.53 D29.53
Recv: echo: M304 P178.25 I30.25 D199.25

I tried to go into the machine settings and clicked
save, check the M503 results from terminal. I did
this 3 times and same results as the last M503.

Selected PID #2 and cliked the checkmark. Didn’t
make any changes from it’s last setting.
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #2 Ext 22.22 2.22 188.22
PID #2 Bed 1.22 61.22 1.22
Recv: echo:enqueueing “M500”

M503 results:
Recv: echo: M301 P1.22 I373.66 D0.20
Recv: echo: M304 P1.22 I61.22 D1.22

Going to try and set PID values from the OctoPrint
terminal again.
Send: M301 P19.44 I19.44 D19.44
Recv: echo: p:19.44 i:19.44 d:19.44
Recv: ok
Send: M500
Recv: echo:Settings Stored (776 bytes; crc 53085)
Recv: ok

M503 results:
Recv: echo: M301 P19.44 I19.44 D19.44
Recv: echo: M304 P1.22 I61.22 D1.22

Looking at the setting from the machine, no
change from the prior values. The 19.44
doesn’t exist when viewed on the printer.

Rebooted printer. Still see the same settings
as I did before the reboot.
M503 results:
Recv: echo: M301 P19.44 I19.44 D19.44
Recv: echo: M304 P1.22 I61.22 D1.22

Still see these settings on the printer.
None of them match the extruder 19.44

Here are the values as currently seen from the
machine PID settings screen.
Group Extr_Or_Bed Kp_or_P Ki_or_I Kd_or_D
PID #1 Ext 20.25 0.25 180.25
PID #1 Bed 178.25 30.25 199.25
PID #2 Ext 22.22 2.22 188.22
PID #2 Bed 1.22 61.22 1.22
PID #3 Ext 23.03 1.03 189.03
PID #3 Bed 0.03 59.03 1.03

========================================================
newplot

newplot (1)

[EDIT 1]

Probably helps if I include what my machine is. Monoprice IIIP plus (aka Wanhao Duplicator i3 Plus). Stock board, not sure the revision. I do have a mosfet for the heated bed. I have also replace the original extruder heating element, since the original died with this one (link). It is also wrapped with a silicone cover. I have been used this since March 2019 without any issues before the Firmware upgrade. I was using a old version before (i think it might have been v2, can’t remember now). Also I had the cooling fan off the entire time.

Some people had the same kind of problems in the past and it was often related to the silicone cover.

But why is it the PID settings don’t seem to be working. If the silicone is providing better installation I should be able to adjust settings to compensate.

Also why can’t I change the PID settings through the USB interface. Why don’t the numbers match when using the terminal commands or the machine settings screen? Definitely feels like a bug in the firmware.

Your message is quite long. I will try to follow it carefully, but frankly it will not in the next few days…

I also found that the settings screen on the printer can’t go higher than 200 using the +/-. If the number is larger than that on the screen the moment you click the dec/increment buttons it jumps to 200 (had it also jump to zero for one case) and will not let you go higher than that.

I managed to get all my PID settings for my extruder to zero. K=0.02 I=0.02 D=0.02 (didn’t do absolute, since I didn’t want to cause any divide by zeros cases), still have zero affect on the temperature ramp.