Hot end temp stuck around 136

My hot end had a nasty leak that got all over the hot end. I noticed the hot end temp stuck at 136 degrees.

My issue seems almost identical to this post:

I don’t want to shell out 100 dollars to fix the motherboard. I have a spare thermistor and a daughterboard so if i could point the firmware to a different pin on the motherboard i could just wire it straight in. Is there another pin out i could use that would replace the hot end pins?

thanks!

The only pin that may work is pin #2 on the EXT connector.

Thanks! I will work on changing that in the source code and rebuilding the binaries. Before I continue with it, I was wondering if there was any documentation on the diagnosis page? I am having trouble understanding the values it is showing me. is my Pin2 value normal?

20200314_180040

It is explained in the User Manual under Diagnosis:
https://community.advi3pp.com/t/lcd-touch-screen-guide/

If your EXT pin #2 is connected to nothing, it can take (almost) any value. Seems to be perfectly normal.

It looks like it worked! I am using an after market thermistor and the seller says to use setting #11 for the thermistor value. Is there a way to do that in the settings or do I change it in the firmware and rebuild?

You have to change in Configuration.h and recompile.

TEMP_SENSOR_0

Hot end i am using from ebay says " * NTC 100K thermistor 3950K beta A value.

  • Use TEMP SENSOR number 11 in Marlin"

When i used sensor 11 in the firmware it still reads around 5 degrees at room temp. When i plug the thermistor into the bed sensor it reads around 32 which seems more accurate. Am I correct to be using sensor 11 for my hot end in the firmware or should it really be one of the other sensor numbers listed in the configuration file?

thanks!

Update
I tried using the debug dummy values and those worked. It seems to me that the Pin2 reads if i short it but when i use value 1 and use the bed thermistor it reads at 5 still (I used the hot end thermistor on the bed and it reads at 30 so i know both the hot end and bed thermistors work).

Not sure why any thermistor value and any thermistor would make it read around 5-7 degrees. Any suggestions?

Also the firmware version shows a 0.6? not sure if maybe that’s because my lcd is running on one release older or if there’s something wrong with my firmware flashing.

You have to flash both firmwares. Use always the same versions for both.

For your thermistor reading, maybe your mainboard pin is damaged.

If the manufacturer says to use the value 11, you have to use it and the problem is probably something else.

Flashed the LCD and point the hot end to 11. it reads at around 5C :frowning:

if i short the pin it rockets up to 800ish so it seems to react properly i just can’t get it to play nice with this sensor. anything else you think i could try to save this printer?

thanks!

Looks wrong (far too high). I will check on my side.

I am attaching a few pics to help show what I have been doing.

I set the hot !end temp to pin2 like you suggested and the pin seems to react like it should.
Shorting the pins raises the temp over 800 and plugging into the thermistor set to sensor 11 gives barely a response. I am unsure if there needs to be an additional setting changed so that everything scales properly. I feel like maybe there needs to be a resistor added or something to get the values to scale properly.

20200321_115456 20200321_115358 20200321_115413 20200321_115437

Probably, and a capacitor also. As the schematic of the printer is not public, hard to know exactly.

From my measurements:

  • 0 corresponds to -15°C
  • 25 to +295°C
  • 999 to +10°C

So it is not a linear function. Impossible to get 800°C.