Help needed unable to flash the LCD touch screen

Hi everyone i’m new here I have had my printer just over a year and thought its about time I installed this software.
I have a Wanhao duplicator i3 plus with V5.1 mainboard.
I have the DMT 48270M043_05WT LCD panel.

As i’m a supporter I have downloaded from here the binary for ADVi3pp-Mainboard-4.0.6.hex for V5.1 mainboard
For the LCD panel do I just need LCD-Panel part microSD disk image ADVi3pp-LCD-4.0.6.img.zip or do I need the LCD-Panel part raw content as well.

I have used the linked balenaEtcher to write the image to the 8GB Micro SD card and and it tells me its completed ok I see the files are there. I have done it zipped unzipped. I’ve even picked up the files and manually placed them on the SD card.
I have put Micro SD in slot of LCD screen and turned on the printer I get a blue screen for a few seconds the it goes blank and I see NO images being loaded.
I’m sure i’ve missed something simple and that’s why it won’t work.
Thank you in advance.

dasco

One or the other. They are the same in different form.

What operating system are you using?

Win 10 I have got it to flash but part of the screen is not showing whole page or has part of the wanhao logo showing. I tried to change the filament but you cant see the add or remove button but touching screen will eject the filament took ages to get it to add.

Update
I have just flash LCD and printer firmware again in case it was corrupt in some way. I have control of the printer through Cura on the PC, but now just have a blue screen on LCD.
Thanks for fast reply.

You are sure the microSD is no more in the slot? Just a blue screen?

I read elsewhere to try flashing again which I have just done it flashed through the images and stopped and didnt change from the control page at which point I turned off. I then removed the micro SD card and switched back on I now have the control page but no touch screen, if i touch screen lots of times I get blue screen with a + in top left corner if I touch this the + moves to top left touch again it moves to bottom right again and it goes back to control page.

This blue screen is the calibration of the LCD panel.

Ok I just read this here

http://www.wanhao3dprinter.com/FAQ/ShowArticle.asp?ArticleID=79 and these instructions

Can I run the formatting image from that then rerun your firmware image.
Would that work?

They (Wanhao) said so. So maybe.

So have I broke my LCD screen unless this LCD formatting works

The LCD is sometimes difficult to flash especially when creating the microSD from Windows. Could also be your microSD itself. Some people were having similar issues in the past (and this is the same for the stock firmware: it is related to the LCD itself). Flashing another version than 4.0.6 helps sometimes.

So I recommend:

  1. Try the “formatting” image from Wanhao. It helps some people
  2. Try another microSD card. it is better with a 8GiB one, but if you have only one, you cam try a bigger
  3. Try with another operating system if you can (Linux for example).
  4. Try flashing another microSD image (stock, another version of ADVi3++, …) then 4.0.6

I have managed to load up the Wanhao LCD screen and firmware some pages are missing ie levelling page is whitebut touch pad works just cant see it.
I am going to try your software again I can run Linux on my pc from a boot disc and will flash microSD from there and see what happens.

This is so strange.

So ok I re-downloaded ADVi3 LCD and Hex files. Had two attempts to load the LCD disc image on second go it flashed through all of them and stopped at the last boot image turn printer off and back on again and uploaded the Hex file. Restarted printer and checked all pages it seems like they are all there as far as I can see. The only thing missing is it don’t show version number 4.0.6 it just has - - - but I can live with that. It was a bit of a mission but got there in the end.

Cheers Sebastien.

This is not normal. Have you turn off (completely, including removing the USB cable if any) the printer?

I have now turn it on off twice and it now shows the version number so all ok thanks.
It was a brand new MicroSD card as I only had 128GB ones so ordered it in special for this.
I’m now wondering if it is the MicroSD socket on the LCD that was causing the problems but not having a reliable connection.

For what it’s worth I ran into this same issue. Rebooting the printer twice caused the version numbers to display properly. Same printer as you Dasco. Another symptom I noticed is that upon the first power cycle after flashing the intro video does not animate. It just shows a static image of the printer and then goes immediately to the main menu.
Not a problem for me but thought I’d throw my 2c out there just in case it helps with troubleshooting in any way.