Extruder Problem in 4.0.3 with BLtouch on Monoprice Maker Select Plus

Let me list what is going on for clarity’s sake.

  1. I have a Maker Select Plus
  2. The printer worked flawlessly with 3.0.2 without BLtouch
  3. The printer worked flawlessy with 3.0.2 with BLtouch using Teaching Tech’s changes.
  4. Flashed 4.0.3 with BL touch and all hell broke loose. Every print (trully) would stop extruding mid print.
  5. Flashed back to 3.0.2 without BLtouch and it again works great.
  6. Any ideas? Is there something I’m not doing? I actually thought the printer was toast when I started having problems after flashing 4.0.3. I really like the firmware because it seems to add so many of the Prusa touches that the original didn’t have.

I do not have explanation. Can you check carefully your connections, especially the board behind the printer? I get one request in the past similar to yours and it was both a coincidence and a cabling problem.
Let me know if it persists.

Do you remember what type of cabling problem?

The flat cable was not well plugged into its socket.

I’m wondering if that little circuit board behind the extruder might be causing problems. It prints partial Benchys and what it prints is done really well, then it just stops extruding.

This board is often the source of problems. It is a weak point of the printer. If you have a multimeter, you can do a continuity check. The schema can be found here (under Interface Board):

http://sebastien.andrivet.com/en/posts/wanhao-duplicator-i3-plus-3d-printers/

I also can’t exclude a problem with the firmware. A lot of people (me included) are using it without such problem, but who knows with hardware and software.

If you find nothing obvious on the hardware side, i can try to modify the firmware if you want to make some tests.

I’m going to see if I can find a new board. Switch it out and see what happens. A tiny crack can cause all sorts of problems. I check back in and let you know how this works out. For what its worth, I don’t think its firmware related anymore.

It was heat creep due to using one of those stupid silicone sleeves on my heater block. Ended up switching out the entire hot end except the extruder motor, the extruder fan, and the heat sink. Everything else is brand new. Bought some of the heater block cotton and kapton tape for the new heater block and it printed better than it ever did. Finished my first print in …2 months. This is what I get for making too many changes at once. You don’t know what caused your problem. Thank you Sebastian.

I have a Wanhao i3+ with an original BLTouch. I also experienced extruder problems after upgrading from 3.x to 4.0.3.

Heat creep is not a plausible cause in my case. Cause the problem comes right away. No time for creep anywhere. And the problem started right after flashing to version 4.

The first problem I saw was that the LCD didn’t always respond as expected. E.g. when asking it to extrude it sometimes started slowly descending the z while the x axis slowly glided toward the right. But only some times. I suspected this could be because a loose cable some where, but I could not find anything wrong anywhere.

When trying to print, I got serious extrusion problems. First I thought it was something to do with cura f-ing up. It looked like coasting was turned on, since the filament always ‘ran out’ before direction shifts. But when trying to print already sliced models from earlier, the printer struggled with that as well.

Anyway - after a lot of grief and trying this and that, I flashed the printer with it’s original firmware last night. The next print (still a pre-sliced model) came out perfectly without any problem.

It’s hard to conclude that this is not caused by something in the 4.x firmware. I know it works perfectly for a lot of people, but if I’ve learned something from 25 years as a software developer, that doesn’t rule out a bug : The (potential) bug might just be more obscure and harder to find… …only shows up if the printer is in a room with a given temperature above the arctic circle if the motherboard was flashed on a Wednesday night…

Software is hard. I really appreciate you effort.
ADVi3++ is a huge improvement over stock firmware, so I’ll definitely try to flash again.

It looks like it has something to do with the settings stored in the EEPROM. Like if they were not reset during the upgrade from 3.x to 4.x. Try to reset the settings and if it does not help, I have a script somewhere to wipe the entire EEPROM content. Let me know if you need it (you will have to use Arduino IDE or similar).

That could be.
I’ll let you know when I’m ready for a new attempt.
Right now, I need a stable Christmas gift producer :stuck_out_tongue: