Extruder motor will not feed after flashing BLTouch firmware (Maker Select Plus 15711)

Extruder motor stopped feeding altogether after flashing BLTouch firmware (Maker Select 15711)

I have tested this issue using multiple googled methods and firmware versions and verified its a firmware issue unless someone can find something I missed. I tested every part and the only point of failure I can locate is in the firmware.
First I installed the BLtouch via this site’s guide, used the adjustable mount found here and verified the stepper motor via other ports, and independently with a spare LED. The motor was the first thing I ruled out. Second: I verified continuity on all cables with a multi meter. Third I re-flashed to 4.0.2 with BLTouch V3 and 4.0.3 with BLTouch V3 and without Bltouch. Right now the printer extruder is working because I rolled back my BLtouch install. The BLtouch worked and functioned even though the extruder did not while i was troubleshooting. I’ve check stepper voltages and all came in right at .9. Pictures of my meltzi board to follow.
https://drive.google.com/open?id=1-LM9U-IigLB3ysw70L0BRI_dsEyppN3e





Hi,
So if I understand well, you are the only one (over maybe 200 or more) to have this problem but you think it is the Firmware?
I take a plane in a few minutes and will be traveling during next week so I will not be able to help you before beginning of August. But I doubt it is a firmware problem unless someone else has the same problem.

(And you do not have a Melzi board… some people are saying that but they make a confusion with the non Plus printer)

It may also help if you post pictures of your BLTouch

Ok. Bought the BLTOUCH from Antclabs, it’s v3.0 the picture will be linked below. I don’t THINK it’s the firmware, I KNOW it is, I’ve literally ruled all other things out. Swapped cables and ensured the motor works, ensured the winding works with LED. Tested continuity on all cables. Checked stepper motor voltage and rolled back bltouch install after which the extruder now works fine. Unless you know of a step or something I missed then yes I’m sure its firmware. Picture to follow.

Actually it’s interesting you say this. My extruder stopped working, and I assumed it was a stepper driver that fried. I got a replacement and that worked, but then the extruder stopped working again. I chalked it up to a defective board and got a replacement under warranty/good faith. The first replacement worked for a week before it stopped, and I’m not sure if it was around the time I flashed up to a new version. I will keep an eye on this board and see if it too stops working at some point (the extruder). I did get a funny response on the board I just replaced - after a cold boot, and I brought the Hotend up to temp, when I hit the manual extruder jog, the build plate would brieflly move then stop. After that it would not do that and the extruder remained unable to function.

1 Like

Glad to see I’m not alone. I’m about to run a test print without the BLtouch to see if it prints normally.

If it happens again to me I’ll try downgrading. I did try that using 4.0, 4.01, and 4.02. Did you go to 3.xx to get it working?

without BLTouch it’s working on 4.02, probably 4.03 too. There has to be something firmware wise that is preventing both the BLtouch and extruder from working on that bltouch version of the firmware.

I didn’t consider flashing a non BlTouch package. I’ll keep that in mind. If I didn’t already trash the old board I may try plugging it in and trying that to see if it will do anything in my particular case. The last time it stopped, I had finished a print and launched a new build and noticed no filament was coming out.

So test print successful on non BLtouch firmware.

I ran into a weird thing with this new board, also extruder related. Mid print, the extruder would just extend/retract, and not just extrude. Even after I stopped the print, and manually jogged the extruder, it would exhibit the same behavior - go back and forth with the stepper motor, not stick to one direction. After powering down and leaving it like that for a minute did it start working correctly again. I’ve seen this before with the other boards prior to this new one.

Nope still not straight. Works without bltouch firmware fine.

The only thing to check, and I got caught on this before with this printer, it’s got a cold Hotend limiter. If the target temp isn’t met, the extruder will not operate at all.

Already tried that. Heated the whole thing to temp and nothing on that bltouch firmware, 4.02 or 4.03.

Just to update, printer is printing small prints on 4.03 non Bltouch firmware fine, but larger ones are now stopping mid print and LCD cycles the startup over and over. Bltouch install still not working with its firmware. Thanks.

Hi Deelow,

I don’t think I have your knowledge or experience, but is it possible that the BLtouch unit is defective in some way? Have you had reliable results with another firmware/older version?

Kind regards,
Scott

No it works fine, but the extruder stops working as soon as that firmware is flashed. So the Bltouch will work, but the extruder won’t.

1 Like

Hi Deelow,

I was wondering if some issue with the BLtouch maybe impacting the extruder? Just considering iterations.

I did go through the wiring and double check the connectors. Nothing was out of place nor were voltages off or anything.

1 Like

With such a conviction, I am not sure to be able to help you. I can reply “I am not sure this is not firmware related” but it will not help much, isn’t it?

So can we try to collaborate to try to fix your issue with an open mind?

1 Like