Distorted images on LCD Panel

So, I’ve been trying to get my di3plus updated to the current firmware. I have added a bl touch to it. I believe I am running v3.0 of the adv firmware.
I try to update the LCD and get to the part that shows an actual printer, and it hangs and gives me distorted images.
I am using a 2gb micro SD card.
I swapped it for another one, same problem, even tried a 16gb in the off chance it would work. Bought a new ad card reader thinking it might be corrupting the files. Nothing is working for me.
Step 1 I download the .img zip file for the LCD.
Step 2 Load up the etching software recommended on the how to page.
It writes the file just fine.
Step 3 insert the ad card to my di3plus
Step 4 turn on printer.
Step 5 curse in frustration when it still doesn’t work.
Some one please help.

What happen when you insert the microSD is the slot of the LCD panel?

It is not very clear what you are doing.

Autocorrect. Should have read sd

Once the img is etched I insert the card to the LCD.
Turn on power, and it goes to blue screen then cycles through the graphic screens. Once it makes it to the pic of the actual printer it hangs and goes to a messed up screen. None of the graphics are right. And it has vertical lines across the display

FB_IMG_1561579025404

Note: Next time, please create a new topic under Get Help.

Your problem looks like the problem of @Bretzel (https://community.advi3pp.com/t/lcd-display-brick/). Are you running under Windows? Some people have reported strange problems due to their anti-virus.

Sorry. The format here is odd to me I couldn’t find a new topic tab.
I tried with antivirus off. But still no luck. I followed the instructions perfectly. I’m really at a loss here. There is hardly anyone that can help. I don’t see any answers or real fixes. I was so excited to upgrade and now I have a dead printer

I have even tried to flash back to version 1.0 with no luck. I’ve tried unplugging the bl touch.
I’m plumb out of ideas.

is it possible, since there are 2 models of the lcd, that mine is not supported with the lcd firmware?
I am looking into a replacement but am having a heck of a time finding one.

Yes, there are two, but both are supported (I bought both to be sure). You can find several on the internet. For example on AliExpress:


Be sure to take the Touch one.

The problem with AliExpress is it takes a month to get. And then I don’t know fully if the LCD I’d actually defective. It will continue to try to install if I turn it off. It will go through the process untill it gets to the end and messes up

For the moment, I do not have a solution to this problem. It happens also with the stock firmware so it looks like it is related to the LCD Panel itself.

update…
I have tried not using the etcher software and the img file. I have just unzipped the raw files and copied them to the printer. I can get 4.02 to work (I think).
it does not give me the distorted panel anymore. It just sits on a control screen. When the lcd is done flashing does it tell me it was successful? Also now for some odd reason, cure will not see my printer, but my simplify 3d does, repetier does and my pc does. So I cannot get it to flash the board firmware now.
In cura I cannot find a way to see if the baud rate and such is correct.
any ideas would be helpful.
Btw, I have downloaded the img.zip on 4 different computers, as well as a mac. same result every time. Is there a possibility the source is corrupt? If I attempt to open the .img, after extraction, windows tells me the file is corrupt.

No

There is no way in Cura to select the right port and the right baudrate.

I think that around 200 people have flashed without any problem. I just check on Windows 10, and no, it is not corrupted. I can unzip the .img.zip without any problem. But it is not possible to open the .img with Windows. It is a limitation of Windows.

But if you use (for example) 7-zip, you will see you can open it. macOS has also no problem to open it natively.

Are you sure you do not have an anti-virus running on your machine?

Yeha I have turned off all windows anti virus.

Have you tried what is explained here:

https://community.advi3pp.com/t/alternative-ways-to-flash

yessir I have. The manual way got me the best results. But still failed

Ive got the main board to flash again. so it is on 4.02

ok, so I am having a hard time beliveing the lcd panel is bad from just trying to upgrade the FW.
the reason I feel this way is it gets all the way to the end of the boot process at 227_boot then fails.
There has to be something I am doing that causes this.

I do not understand what that’ll mean

If you look at the dwin set file it has all the pictures that it loads. It stops at the very last one