Cocoon Create Touch freezing with 4.0.6

Hi folks,
I decided to revive my old Cocoon Create touch printer, since I am am planning to use it for exclusive TPU printing. Of note, I upgraded the hot end to Swiss full metal extruder, including nozzle.
Upgrade went smoothly for LCD and main firmware - I used microSD method for LCD and Arduino compilation and upload for main firmware.
Everything works fine when calibrating printer - PID, eSteps, etc.
However, printer freezes completely between 1% and 4% of printing. I tried 2 different SD cards and 2 different models sliced in Cura 4.8, same issue. When frozen, touch screen beeps on contact but nothing happens, printer must be switched off and back on to recover.
Any ideas? What can I try? I did re-flash main firmware from Arduino IDE just to be sure.
EDITED: I used Cura 4.8 in Windows to flash directly the 4.0.6 HEX file, same problem. Sudden freeze during printing.

Most of the time, this kind of behavior is when the SD card is defective or not well formatted. But you said that you try with 2 different cards. Perhaps, you should try to reformat the SD cards and retry. They are maybe both corrupted (from a FAT point of view).

Yes, it looks like the firmware reboot and was then stuck in a boot loop.

It is possible that the flash memories in the MCU is corrupted. Either the code flash or the EEPROM. It may work to flash again and to reset the EEPROM.

Hi, ok I have done more experiments:

  1. The printer works fine when printing directly from Cura 4.8 via USB.
  2. I tried a brand new 16 Gb SD card, and while it can see the GCODE file on it, it stops after just after the first or second layer.
  3. I tried another firmware, same issue.
    So it appears that I have a malfunctioning SD card slot, likely contacts got oxidized (printer has been in storage for a long time). It looks like I might have to replace the motherboard. Do you have a recommendation so that it could be an upgrade rather than just a repair?

There is no “upgrade” available for this printer.

I have had some success with DeOxit on oxidised contacts. I don’t know how to get into the SD slot, but Deoxit comes with very thin brushes to get into narrow holes. The liquid (as opposed to the spray) sells here in OZ for ~$AU30.

Gonzo

I tried cleaning it but it is so unreliable and stops randomly. Therefore, I am printing only via USB from a host, I installed OctoPrint on an old notebook running MX Linux, it works fine this way.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.