Choosing the correct pre-built firmware for my WANHAO Duplicator i3 plus MKII printer

I have joined the community as a Patreon and have the following 3D printer - Wanhao Duplicator i3 plus MKII. I have downloaded the files listed below - ADV13pp-LCD-4.0.5.img.zip and ADV13pp-Mark2-Mainboard-4.0.5.hex Before I use them can someone please confirm that (a) they are correct for my printer and (b) that the auto bed levelling functions are present within the new firmware, as I would not wish to lose that facility? Kind regards. Dennis.

Yes

Yes.

It is better to use the latest version, i.e. 4.0.6.

Thank you. I will download the version 4.0.6 :+1: