Bug. Move option after stopping printing

When i stop a print (by the way it takes like 5/10 s to stop. Is this normal?), i go back to the main menu, start pre-heat, and if i after this try to move the Z axis up, the printer starts to move the x and y axis slowly (from the left/back to the middle of the bed) I can’t stop this movement. After some time it stops. One time after i tried again to move the z up it went down and i had to turn off the printer to not risk the bed. This onyl happens when i stop a print and try to move after it.

Also when i try to move before a printer (for example z up) the printer first moves a bit of the X/Y (like 2mm) and only then the Z.

Monoprice select plus on t he latest firmware for bltouch v2.2.

What could be doing this?

Please provide more information like:

  • How do you print? From a SD card, from USB, …?
  • Which slicer?
  • What is your starting gcode?

SD card, Cura.

Starting code:
G21 ; Set metric values
G90 ; Set absolute positioning
M82 ; Set extruder to absolute mode
G28 X0 Y0 ; Move X/Y to min endstops
G28 Z0 ; Move Z to min endstops
G1 Z20 ; Raise the head
M140 S{material_bed_temperature} T0 ; set target bed temperature
M190 S{material_bed_temperature} T0 ; set target extruder temperature
M104 S{material_print_temperature} T0 ; Wait for bed temperature to reach target
G29 ; Auto-leveling
G1 X0 Y0 F3000 ; Go to home (without homing: it would disable compensation)
M109 S{material_print_temperature} T0 ; Set extruder temperature and wait
G92 E0 ; Zero the extruded length
M300 ; Play tone
G1 Z50 F1800
G1 F140 E30 ; extrude 30mm
G1 X60 F1800
G92 E0

I have also had this happen with my Cocoon Create Touch.

Another Cocoon Create User here seeing the issue, I had it both prior and after installing the BLTouch

Can you please give the exact model number of your printer and which file you have used to flash it?

Only after 6pm can i give you the model number, but the file was this one: ADVi3pp-BLTouch-Mainboard-4.0.3.hex.

Edit: Also i used Cura to flash.

If you have model “HE161192”, it is correct.

I am using a HE161192 (Cocoon Create Touch - Australia) and used ADVi3pp-Mainboard-4.0.3.hex (Pre BLTouch) then ADVi3pp-BLTouch3-Mainboard-4.0.3.hex

Like @Joao_Ribas if I move my Z up I will see the X and Y jog very slightly before the Z starts to move. But at times, if I have cancelled a print job and then attempt to move the Z up to clear the nozzle the X and Y will start to move away from home and the only way to stop it is to power off the printer.

On amazon it says 121871, which i will assume it is the 21871 in this list of yours:https://github.com/andrivet/ADVi3pp/issues/188.
i bought it from amazon (es) and the store is monoprice uk so i’m pretty sure it is the monoprice select plus from the uk.

Here is a picture from the mainboard if it helps. IMG_20191119_175149

I just want to say again, that even when is heating the bed if i click stop (square) the printer does nothing!

Yes, I heard you. I will try to reproduce what you see. But it is not the case so far.

i have the UK Aldi Balco touch with the touchscreen but no usb port with BLtouch installed. I don’t think it is slicer dependent as I’ve used Cura, Pruser Slicer and Simplify3d.

I too experience the same when I stopped a print midway. After that its’ behaviour is unpredictable similar to what has been mentioned above. Also when I start a print after previous abortion, it start printing from a different point on the bed (like its origin point has shifted) and depending on the model size, it has tried to print beyond the bed dimension causing a physical crashing action to the sides. This only has happened 2 or 3 times, so is a rare event and difficult to reproduce on demand.

I now turn off the printer whenever I aborted a print to be safe before printing again.

I have an wanhao i3 plus using the bl touch v3 firmware and my printer do same behavior , printing from SD and slicer simplfy 3D. Thanks

I am using a HE161192 (Cocoon Create Touch - Australia) and use ADVi3pp-BLTouch3-Mainboard-4.0.3.hex. My problems occur after cancelling a print. If I try to raise the z-axis or move X and Y I find the printer seems to lose its sense of its position and will tend to crash into the frame of the printer. It is as if the act of cancelling the print inserts false location data into memory. The only way to resolve the problem is to turn the printer off, wait a while and turn it back on again. After doing a restart everything is fine.

I think I have a bug in the firmware somewhere related to SD printing and stopping. This is not the best tested part, especially because for my day to day prints, I do not use printing from SD and I never use Stop.

I will look at this more carefully. I will create an Issue on GitHub if necessary.

@andrivet I reported this bug in GitHub issue #219.

Salty Doug