Bltouch suddenly stopped working (unclear if firmware or hardware issue)

Hey everyone, I’m suddenly having a weird BLtouch issue. It’s worked perfectly for over a year at this point. I didn’t change anything. I have been using Advi3++ 4.03 both firmware and screen since they came out successfully, I was and am using that with a Maker Select Plus printer. It was working one night, and the only thing I did right before it stopped working the next morning was changing out the Y and X rods (which clearly shouldn’t be related).

It is now responding properly to the M280 commands to test, reset, deploy, and stow. When the printer turns on it properly tests itself. It doesn’t throw any noticeable errors. However, M401 and M402 don’t do anything anymore, and when trying to level, it moves to the center of the bed, flashes the blue light once and then resets the connection to the computer.

Things i’ve tried to fix it:

  1. New BlTouch
  2. New Wiring
  3. Checked continuity on all the wiring, individually and collectively.
  4. Wired the touch directly to the mainboard with the printer on its side with the bottom off
  5. Reset the LCD firmware (on the LCD)
  6. Reflashed the firmware and LCD firmware
  7. Recompiled and reflashed the firmware and lcd firmware
  8. Same thing but with default settings (for 4.03 (I had previously made some changes for settings so that I wouldn’t have to enter them on the lcd))
  9. New USB cable
  10. Different USB ports
  11. Different computers
  12. Different programs

It’s baffling to me that it is deploying and stowing correctly with one command, meaning that in theory the orange cable is working properly, but not with another command. I guess the next thing that i’ll check is taking out the motherboard and making sure that the solder from, idk, well over a year ago didn’t somehow get screwed up suddenly??

If anyone has any ideas they would be greatly appreciated. Thanks!

I just tried testing continuity from the bottom of the soldered parts to the Bltouch, which worked. I also tried switching the servo pin (orange one) both physically, and in the firmware to ext 3 (36) after reading another thread here. Same issue

M280 P0 S10 works with the orange in the other pin, M401 does not. I tried taking the orange pin out entirely just to see what would happen and the test that happens when the printer is powered on worked, but M280 P0 S10 did not. This leads me to believe that it has to be some kind of software issue, but I don’t understand how.

Have you tried to reset the Settings? You can also try to erase the EEPROM data with this:


Be sure to put back your Settings after, in particular the position of the sensor.

Thanks Sebastien, I did reset the settings (by using the LCD option), but I’ll give that file a try.

Same issue, sadly. Thank you for trying though.

When this first happened the normal G28 / G29 commands were failing and causing the printer to restart. That started me down the path of troubleshooting by using M401. M401 still is not working, but somewhere down the line apparently G28 and G29 started working again. It’s not clear when since I assumed the problems were related and was therefore only testing with M401/M402, but the printer is working properly other than that, so I guess you can close the issue.

This looks like a bad flashing of your motherboard. It happens sometimes. You can try to flash another version, and then 4.0.5 (or directly 4.0.5 if you have currently a previous version).

I recently had a similar with a non genuine BLTouch on another printer.
The fault turned out the be the BLTouch.
There was some movement on the circuit board as the head moved around.
It would work for the homing and failed when it tried to level the bed.
One of the fine wire for the coil on the top had broken at the solder pad on the circuit board.
I am working on a video of it, as I was recording when it failed and the subsequent repair of it.
I had assumed it was a result of a bad copy of the AntcLab unit.
I hadn’t planned of linking to that video here when I release it as it didn’t involve the CCT or this firmware at all. I can if people are interested, but only planed to share videos here that are about the CCT and/or the ADV++ firmware.
Never had a problem like it on the Cocoon Create Touch.
And a lot easier to set up with the ADV++ firmware as well :slight_smile:

Sebastien,

I’ll give it a shot at some point, and will report back. Now that it’s working again I kinda want to stop screwing with it for a while.

Ray,

That’s interesting, but it wasn’t the issue that I was having as I tried a new BLtouch and the issue persisted.

What was the problem for future reference?

The issue was that when using G28 / G29 the probe would not deploy and instead would restart the printer. Collaterally, M401 / M402 were not working, while the M280 commands were. I’m not sure what ended up fixing the G28/G29 issue, but the M401 issue remains.