Beep toggle option - Double beep?

So far I love the new interface/system. The new layout is clear, the extra options that didnt even come with my printer, and the full utilization of a pretty nice screen is a welcome change. (I thought it was just black and white!)

While poking around in the settings I was excited to find a “beep on press” option to turn off the annoying beeping when moving about the system. Unfortunately, when I discovered the option it was off (despite the beep still playing) and when I turned the option on it sounds like it beeps twice at the same time. Am I missing something or is it just a bug?

I have tried turning the switch on, and then restarting the printer to see if it would quit double beeping so i could turn it off but the beep persists.

Any help is appreciated.

Thanks.

  • Ben

Which printer, model number, version of ADVi3++, etc…? If you are not providing any information, it is difficult to reply.

Whoops,

Maker select plus P/N 15711

ADVi3++ 4.0.3 fresh install.

Thanks.

When do you buy it? It looks like you do not have the same LCD display than what I am aware of. If you have the possibility to give me the model number of the LCD display, it would be great.

Hello. I just flashed my “Balco 3D Printer Touch” from Aldi Belgium and have the same issue.
The flashed firmware is the 4.0.3

Thanks

Can you please give me the model number of the LCD screen?

@andrivet,

Of course, it is the one depicted in this post.


With the picture, I guess you have all the needed information.
If you need something in addition, you tell me.

Thanks

But it is not a post from you. I need a picture of your LCD panel.

Here you are, boss!
IMG_4123

Do you also have the version of its firmware? It is available under Info / Versions.

@andrivet, yes. Here you are:

IMG_4125

I have various test displays including this exact one and with the same DGUS LCD Firmware. So I have no explanation so far.
I have created an issue: https://github.com/andrivet/ADVi3pp/issues/223

Hello there, I just performed the update to 4.0.5

The issue is still there, kind of weird. Do you already have feedback of someone having the same issue but had been solved thanks to the 4.0.5 update ?

LCD: 4.0.5
Mainboard: 4.0.5
Build: 200120232641
DGUS: 2.2
Marlin: 1.1.9

Thanks

I did the upgrade to 4.0.4 on Saturday before I saw that 4.0.5 was posted and I got the double beep and it didn’t turn off when toggled. Just upgraded to 4.0.5 and still get the beep. This is a Wanhao i3 Plus Mk2.

LCD: 4.0.5
Mainboard: 4.0.5
Build: 200120232655
DGUS: 2.2
Marlin: 1.1.9

Btw, thanks for the firmware. I’ve struggled with this printer for a year now with mods/upgrades/firmware/replacing parts with marginal results. The printer is working much better with your firmware! Thanks Sebastien!

Please tell me the exact model number of the LCD panel. It is written on its back.

To follow up on this issue: I have two LCD panels with the exact same model number DMT4827M043_05WT and I do not have this problem.

So I have ordered a new one (from AliExpress) and I will exchange it with one of those problematic panels. I hope to be able to find a solution.