Bed won't level since BLTouch Install!

Hey guys!
I’ve installed the BLTouch sensor this morning, word by word from the manual. It seems to be functioning perfectly. I manually levelled the bed using the guided levelling, and the level is perfect except a very slight low spot in the centre of my bed. I then set the z-height with the exact same feeler gauge as the manual level.

However, when I then go to do auto-levelling:
120928159_3655685334441994_5992225742587309184_o
I get a grid like this!

Whenever I try to print, the nozzle starts above my set z-height and nothing sticks! What should I be looking at to solve this? Software/firmware changes? Bent X-rods? Am I following the levelling process incorrectly?

It was printing perfectly yesterday as I printed a new cooler and mounts for the BLTouch!

Many thanks,

Matt

You can look at this, especially the last part:
https://community.advi3pp.com/t/the-left-side-is-too-close-the-right-side-is-too-high-or-the-contrary/

I have blueprinted the printer when I re-assembled - everything is square on the machine and I have z-braces installed to keep it square. my bed is very slightly warped on the left side now I have checked it with a straight edge.

However, I still don’t feel like my bed levelling is being applied to the print! If I’ve set the z-offset correctly, and then ran auto levelling, it should compensate for this slight warp? Yet the nozzle begins printing slightly away from the build surface and “blobs”. How do I make sure the ABL is being applied to the print?

Yes.

The sensor indicators should be orange. If it is gray, compensation is not active.

Have you looked at the “Twist on the X axis” part? It is the most common reason why the compensation is wrong.

I’ve re-tried all of those steps just in case, the result is the same :frowning:

The Sensor Icon is orange

Can you give some context? You are not telling which printer you are using, which BLTouch version, etc.

The printer is pictured above - Wanhao Duplicator i3+, latest version of ADVi3++, BLTouch Smart 3.1, connected exactly as in the manual :confused:

Is there a way to disable ABL for a print and use manual levelling, to test if it’s the printer or the ABL?

Oh, I am supposed to immediately recognize your printer from this very dark picture. Sorry, I am not. Not even able to tell if it is a Mark I or II.

Not easily. The only way I see it to reset the settings (it will reset the ABL mesh as well).

Apologies - I didn’t realise that photo had been so badly cropped, this is a better picture:
120939525_816464442513549_3024782938288033737_n

I believe it’s just a standard MkI i3+? I’ve had it for several years.

When you settings do you mean the firmware and reinstall the z-stop? Or just reset the printer settings? :slight_smile:

I think it may be related to the Noctua fan… I’ve thrown in some old PLA rather than the ASA I usually print with and it seems to be working? Is it possible for poor cooling on the heatsink to prevent bed adhesion? Because I’ve followed your instructions really thoroughly and I can’t seem to find anything that’s out of level or square on my machine :man_facepalming:

Yes, printer settings (reset).

Hi Matthew,
I encourage you to keep testing and checking. Once your BLTouch is installed and machine tuned, you’ll love it with ADVi3++. Some suggestions :

  1. If you are concerned about your hotend cooling set up, do a PID tune.
  2. Have you confirmed that the base of your BLTouch is 8.0 - 8.5 mm above the bed as required ? I printed the height gauge (https://www.thingiverse.com/thing:1538742) which helped.
  3. ADVi3++ v4.0.6 allows you to enter the X and Y offset position of the Nozzle relative to the tip of the BLTouch to account for different ABL sensor mounts. Recommend you measure and enter this value.
  4. Do a live manual bed level. Eg: Print a calibration cross and dial in the bed thumbwheels during the print based on how the first layer is sticking.
    Hope this helps.

Can you give more information about your setup: which operating system are you using, do you use OctoPrint or similar, etc. Please give enough information. This to known which tools you have available in order to help you troubleshooting.

Thanks very much for your help Ian, however I have done all of these steps with no change.

I am using Windows 10 x64 Home, Cura 4.7 straight to SD card - printer. I export my models straight from Fusion360 as .STL objects then open in Cura, using my tried and tested settings that I’ve used for approx. 4 years before installing the ABL :slight_smile: