Bed temp issues

At first, the bed just started heating up too much and then triggered thermal runaway. Then I unplugged the thermistor from the main board and noticed it didn’t trigger mintenp and was reading 23c. Tried reflashing firmwares, reseating cables. Didn’t see any corrosion, bridged pads or cut traces, but took out board and cleaned it anyway. Nothing worked. Still reads 23c on the dgus screen and octoprint even with nothing connected to the board except the screen.

UPDATE: the temperature isn’t stuck at 23, it fluctuates between 21 and 25.IMG_20200519_153630 IMG_20200519_153633 IMG_20200519_153657 IMG_20200519_153647 IMG_20200519_153753IMG_20200519_162035

Is your bed heating? If not, it looks like a hardware problem, your MOSFET has burned.

Why do you think it is a problem with ADVi3++ firmware?

My bed does heat up but the printer doesn’t detect it. Would this be fixed by adding an external mosfet?

There are two things:

  • the heating. This is what the MOSFET is doing
  • the temperature reading. This is performed by a thermistor.

Since your bed is heating up, it is probably not the MOSFET. Something that happens frequently is that the wire to the thermistor is cut somewhere. Another common problem is that the thermistor become loose. It stayed in place with some Kapton tape and with the movement of the bed, it get loose. It could be also that the thermistor is defective.

As this is not related to the ADVi3++ firmware but to some hardware problem, I am moving this topic in a more appropriate category.